Ask Your Question
0

rosmake error

asked 2012-11-28 01:34:02 -0500

clee gravatar image

updated 2012-11-28 04:11:55 -0500

joq gravatar image

hi

i am getting error below when i am trying to rosmake rviz

[rosbuild] Building package rviz
[rosbuild] Cached build flags older than manifests; calling rospack to get flags
Failed to invoke /opt/ros/fuerte/bin/rospack cflags-only-I;--deps-only rviz
Package sensor_msgs was not found in the pkg-config search path.
Perhaps you should add the directory containing `sensor_msgs.pc' to the PKG_CONFIG_PATH environment variable
No package 'sensor_msgs' found

CMake Error at /opt/ros/fuerte/share/ros/core/rosbuild/public.cmake:129 (message):

It is complaining that sensor_msgs.pc is not in PKG_CONFIG_PATH However, the sensor_msgs.pc is in the config path when i check it.

:~/fuerte_workspace$ echo $PKG_CONFIG_PATH
/opt/ros/fuerte/lib/pkgconfig:/opt/ros/fuerte/lib/pkgconfig:/opt/ros/fuerte/lib/pkgconfig

:~/fuerte_workspace$ find /opt/ros/fuerte/lib/pkgconfig | grep 
sensor/opt/ros/fuerte/lib/pkgconfig/sensor_msgs.pc

Does anyone encounter this issue before? Thanks

edit retag flag offensive close merge delete

Comments

Looks like you are sourcing /opt/ros/fuerte/setup.sh three times. That might cause problems. But, @Lorenz is right: just install ros-fuerte-visualization.

joq gravatar image joq  ( 2012-11-28 04:18:00 -0500 )edit

3 Answers

Sort by ยป oldest newest most voted
0

answered 2012-11-28 04:02:57 -0500

Lorenz gravatar image

Why are you building rviz from source? Just install the debian package:

sudo apt-get install ros-fuerte-visualization
edit flag offensive delete link more
0

answered 2013-05-29 00:08:02 -0500

I had the same problem, but was due to move a package of "Electric" to "Fuerte". A new node that wanted to build, needed some libraries from other nodes. To do this, these nodes had to export some flags in its manifest.xml specified include path or/and lib path. In the main node cmakelist just had to make a standard target_link_libraries.

<export>
<cpp cflags="-I${prefix}/include" lflags="-L${prefix}/lib -Wl,-rpath,${prefix}/lib -lros -lname_your_libraries_that_you_like_export_to_other_nodes"/>
</ export>
edit flag offensive delete link more
0

answered 2012-11-28 11:56:19 -0500

clee gravatar image

I am trying to follow the rviz user guide rosdep install rviz rosmake rviz.

However, i add a step my self getting the stack in my workspace. So, sudo apt-get install ros-fuerte-visualization didnt works as i got a rviz in my workspace. I fix it by removing rviz from my workspace and .rosinstall

edit flag offensive delete link more

Comments

Please read the support guidelines before you post. Do not create answers for discussion, subsequent questions or comments. Instead, either edit your original post or use the comment functionality.

Lorenz gravatar image Lorenz  ( 2012-11-28 23:36:16 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2012-11-28 01:34:02 -0500

Seen: 587 times

Last updated: May 29 '13