Ask Your Question
1

How do you install a rosdep dependency under catkin/groovy?

asked 2012-11-24 09:46:34 -0500

Ken gravatar image

I've added these lines to foo/package.xml

<build_depend>mylib</build_depend>
<run_depend>mylib</run_depend>

and this to foo/CMakeLists.txt:

find_package(catkin REQUIRED COMPONENTS mylib)

and I added this rule to my local rosdep yaml file:

mylib:
  arch: mylib-syspkg

but when I run rosdep keys foo, I get a blank line, and if I try rosdep install foo, I get "#All required rosdeps installed successfully". A rosdep resolve mylib call prints out "mylib-syspkg".

If I run catkin_make:

CMake Error at /opt/ros/groovy/share/catkin/cmake/catkinConfig.cmake:71 (find_package):
  Could not find a package configuration file provided by "mylib" with any of
  the following names:

    mylibConfig.cmake
    mylib-config.cmake

It looks as if nothing is associating the mylib dependency with the foo package. Is there some new command I should run to install a wet package's rosdep dependencies?

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2012-11-24 10:04:39 -0500

Ken gravatar image

Looks like it's fixed in rosdep (but not released yet).

$ sudo pip2 install -I https://github.com/ros/rosdep/archive/master.tar.gz

$ rosdep keys foo
mylib
edit flag offensive delete link more

Comments

1

0.10.9 released with the necesary patch.

tfoote gravatar image tfoote  ( 2012-11-24 13:42:28 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2012-11-24 09:46:34 -0500

Seen: 1,067 times

Last updated: Nov 24 '12