rxbag can't load kinect depth images [closed]

asked 2012-11-14 22:45:20 -0500

Antonio gravatar image

updated 2016-10-24 08:34:13 -0500

ngrennan gravatar image

Hi I'm trying to record kinect depth images using rosbag. I type the command rosbag record /camera/depth_registered/image to register depth images. When I launch rxbag and try to visualize depth images I get the following error:

Can't convert image: local variable 'mode' referenced before assignment Failed to load: ('/camera/depth_registered/image', 1352975975.9240148, 0.1, (151,))

Any idea on how to fix it?

Sequence of command:

roslaunch openni_launch openni.launch

rosbag record /camera/depth_registered/image

then I stop the recording and type

rxbag output.bag

In the rxbag GUI interface I click on the Thumbnails button, the interface does not show the images and the terminal gives me the error:

Can't convert image: local variable 'mode' referenced before assignment Failed to load: ('/camera/depth_registered/image', 1352975975.9240148, 0.1, (151,))

I've also tried to visualize the depth image using rviz and it shows the incoming images with no problems, so the topic /camera/depth_registered/image is correctly publishing images.

Thanks

edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by tfoote
close date 2015-09-18 18:48:48.064827

Comments

Please be more specific. Can you please edit your post and provide the exact sequence of commands that you executed to allow us to reproduce your problem?

Lorenz gravatar imageLorenz ( 2012-11-15 00:01:13 -0500 )edit

just edited

Antonio gravatar imageAntonio ( 2012-11-15 03:37:55 -0500 )edit

I guess this could just be a bug in rxbag. Consider filing a ticket.

Lorenz gravatar imageLorenz ( 2012-11-15 04:13:28 -0500 )edit