Ask Your Question
0

fuerte rgbdslam problem with eigen..

asked 2012-11-14 00:16:02 -0500

Oppenheim gravatar image

updated 2014-01-28 17:14:15 -0500

ngrennan gravatar image

Hi.

I'm going to start the 3d mapping project with rgbdslam and octomap. but I'm struggling with rgbdslam.

I installed rgbdslam from source(using rosinstall) and I wrote $ rosdep install rgbdslam

then it said,

ERROR: the following packages/stacks could not have their rosdep keys resolved to system dependencies: rgbdslam: Missing resource eigen ROS path [0]=/opt/ros/fuerte/share/ros ROS path [1]=/opt/ros/fuerte/share ROS path [2]=/opt/ros/fuerte/stacks

there are already many Q&A's about fuerte and eigen problems, but I couldn't solve my problems with them.

This link is the answer already suggested.

But in my case, the manifest.xml file of rgbdslam already contains <rosdep name="eigen"/> instead of <depend package="eigen"/>. Also, I edited my manifest.xml file and CMakeLists.txt as "http://ros.org/wiki/eigen" says, but it was of no use as well.

Here is my manifest.xml.

<package>

  <description brief="SLAM on RGBD Data">

    This package can be used to register the point clouds from RGBD sensors such as the kinect or stereo cameras.

    The rgbdslam node can be connected easily to an octomap_server node to create a memory-efficient 3D map.

  </description>

  <author>Felix Endres, Juergen Hess, Nikolas Engelhard</author>
  <license>GPL v3</license>

  <review status="unreviewed" notes=""/>

  <url>http://ros.org/wiki/rgbdslam</url>

  <depend package="tf"/>

  <depend package="pcl"/>

  <depend package="rospy"/>

  <depend package="roscpp"/>

  <depend package="rosbag"/>

  <depend package="pcl_ros"/>

  <!--depend package="opencv2"/-->

  <depend package="cv_bridge"/>

  <depend package="sensor_msgs"/>

  <!--depend package="openni_camera"/-->

  <!--depend package="octomap_server"/-->

  <!--depend package="octomap"/-->

  <depend package="geometry_msgs"/>

  <depend package="visualization_msgs"/>

  <rosdep name="libqt4-opengl-dev"/>

  <rosdep name="libqt4-dev"/>

  <rosdep name="libglew-dev"/>

  <rosdep name="libdevil-dev"/>

  <rosdep name="libgsl"/>

  <!--rosdep name="gl2ps"/-->

  <rosdep name="eigen"/>

  <rosdep name="libg2o"/>

  <export>

    <rosdoc config="rosdoc.yaml" />

    <nodelet plugin="${prefix}/nodelet_plugins.xml" />

    <cpp cflags="-I${prefix}/srv_gen/cpp"/>

<cpp cflags="&lt;code&gt;pkg-config --cflags eigen3&lt;/code&gt; -I${prefix}/include 
&lt;code&gt;rosboost-cfg --cflags&lt;/code&gt;" lflags="-Wl,-rpath,${prefix}/lib -L${prefix}/lib -lplanning_models"/>

 </export>

</package>

And the eigen part of my CMakeLists.txt

#############################
# Eigen ####################
#############################
find_package(Eigen)

IF(Eigen_FOUND)

  include_directories(${EIGEN_INCLUDE_DIRS})

  add_definitions(${EIGEN_DEFINITIONS})

ELSE(Eigen_FOUND)

  MESSAGE("Eigen package was not found. This is OK FOR ROS ELECTRIC, bad for fuerte\n")

ENDIF(Eigen_FOUND)

Do you have any solutions about this?

Thanks in advance! :)

edit retag flag offensive close merge delete

Comments

Did you do sudo rosdep init and rosdep update at some point before?

dornhege gravatar imagedornhege ( 2012-11-14 00:29:38 -0500 )edit

What dornhege says. Is libeigen3-dev installed?

Felix Endres gravatar imageFelix Endres ( 2012-11-15 04:30:52 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2012-11-19 18:26:20 -0500

Oppenheim gravatar image

Hi dornhege, Felix. I solved my problem. It's the problem of code of pcl which was out of date, so i erased it and reinstall it, it worked. Thanks for your kind answer and upgrading my question to cleaner version :)

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2012-11-14 00:16:02 -0500

Seen: 524 times

Last updated: Nov 15 '12