rgbdslam evaluation freezing(no result) problem [closed]

asked 2012-11-10 01:22:13 -0600

jizhe gravatar image

updated 2014-01-28 17:14:12 -0600

ngrennan gravatar image

My PC os is Ubuntu 11.10, I've followed the instructions exactly to install ROS distribution Electric. Also, I've followed the link [http://www.ros.org/wiki/rgbdslam_electric] & [http://www.ros.org/wiki/rgbdslam_electric/evaluation] exactly to install and run RGB-D SLAM evaluation.

Installation was perfect with no error. But when I run the evaluation with the cmd "rosrun rgbdslam benchmark_evaluation.sh SURF /home/jizhe/ros/rgbdslam/rgbd_benchmark/benchmark_data/", it's been a long time(more than 5 hours) running without any response. So I checked the file "/home/jizhe/ros/rgbdslam/rgbd_benchmark/benchmark_data/logfile", and I found that the logfile's size was becoming bigger at the first time, but it just stopped without any error printing after a while. And the program was running. I have to Ctrl+C manually to terminate the program. The print is here:

......

setting /run_id to a6225460-2b14-11e2-97c2-14feb5ebec29

process[rosout-1]: started with pid [25061]

started core service [/rosout]

Will evaluate RGBD-SLAM on the following bagfiles:

rgbd_dataset_freiburg1_rpy.bag

16:57:26 Results for rgbd_dataset_freiburg1_rpy are stored in /home/jizhe/ros/rgbdslam/rgbd_benchmark/benchmark_data/SURF/rgbd_dataset_freiburg1_rpy

^C[rosout-1] killing on exit

[master] killing on exit

shutting down processing monitor...

... shutting down processing monitor complete

done

17:09:51 Finished processing rgbd_dataset_freiburg1_rpy

Then, I tried to run the evaluation with the cmd "rosrun rgbdslam summarize_evaluation.sh ~/ros/rgbdslam/rgbd_benchmark/benchmark_data/SURF". Here is the print:

......

jizhe@jizhe-OptiPlex-780:~/ros/rgbdslam/rgbd_benchmark/benchmark_data$ rosrun rgbdslam summarize_evaluation.sh /home/jizhe/ros/rgbdslam/rgbd_benchmark/benchmark_data/SURF

rgbd_dataset_freiburg1_rpy

No estimate at level 1

paste: eval_rotational.txt: 没有那个文件或目录(means "no that file or directory")

paste: eval_translational.ate.txt: 没有那个文件或目录(means "no that file or directory")

ATE Results at Level 1 are stored in /home/jizhe/ros/rgbdslam/rgbd_benchmark/benchmark_data/SURF/ate_evaluation_1.csv

RPE Results at Level 1 are stored in /home/jizhe/ros/rgbdslam/rgbd_benchmark/benchmark_data/SURF/evaluation_1.csv

I really have to resolve this problem. Does any one have the same problem or some ideas to solve this problem? Thanks very much!!!

edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by tfoote
close date 2015-06-26 19:44:48.355886