Ask Your Question
0

fatal: unable to connect to code.in.tum.de:

asked 2012-11-01 09:50:07 -0500

HQ gravatar image

updated 2012-11-01 23:11:58 -0500

Lorenz gravatar image

Hi Everyone, I'm trying to install the JNI version of rosjava, and am getting connection failure. Anyone have an idea what's going on with the host site? I've tried three different ways: git, git via rosws set, and sudo. I don't know why the sudo approach failed, but I'm guessing it might the same connection issue. Thanks in advance for any help offered. My steps and terminal output are below.

hq@ubuntu:/opt/ros/fuerte$ roscd
hq@ubuntu:~/fuerte_workspace$ ls
hq@ubuntu:~/fuerte_workspace$ git clone -b cturtle_released git://code.in.tum.de/git/client-rosjava.git client_rosjava
Cloning into 'client_rosjava'...
fatal: unable to connect to code.in.tum.de:
code.in.tum.de[0: 131.159.18.84]: errno=Connection timed out

hq@ubuntu:~/fuerte_workspace$ rosws set client_rosjava --git  git://code.in.tum.de/git/client-rosjava.git

     Add new elements:
  client_rosjava    git  git://code.in.tum.de/git/client-rosjava.git   

Continue: (y)es, (n)o: y
Overwriting /home/hq/fuerte_workspace/.rosinstall

Do not forget to do ...
$ source /home/hq/fuerte_workspace/setup.sh
... in every open terminal.
Config changed, remember to run 'rosws update client_rosjava' to update the folder from git
hq@ubuntu:~/fuerte_workspace$ rosws update client_rosjava
[client_rosjava] Installing git://code.in.tum.de/git/client-rosjava.git (version None) to /home/hq/fuerte_workspace/client_rosjava
WARNING [vcstools] Command failed: 'git clone --recursive git://code.in.tum.de/git/client-rosjava.git /home/hq/fuerte_workspace/client_rosjava'
 errcode: 128:
fatal: unable to connect to code.in.tum.de:
code.in.tum.de[0: 131.159.18.84]: errno=Connection timed out

[/vcstools]
Exception caught during install: Error processing 'client_rosjava' : [client_rosjava] Checkout of git://code.in.tum.de/git/client-rosjava.git version None into /home/hq/fuerte_workspace/client_rosjava failed.

ERROR: Error processing 'client_rosjava' : [client_rosjava] Checkout of git://code.in.tum.de/git/client-rosjava.git version None into /home/hq/fuerte_workspace/client_rosjava failed.

hq@ubuntu:~/fuerte_workspace$ sudo apt-get install ros-fuerte-rosjava-jni
[sudo] password for hq: 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Unable to locate package ros-fuerte-rosjava-jni
hq@ubuntu:~/fuerte_workspace$
edit retag flag offensive close merge delete

Comments

Thanks for the help, Lorenz! You're probably correct that my company's firewall is the cause of the problem. I installed from the debian packages as you suggested and it worked. I'm new to the ROS world and it's great to have help like this. :)

HQ gravatar imageHQ ( 2012-11-02 08:40:08 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
2

answered 2012-11-01 23:14:52 -0500

Lorenz gravatar image

So for me, the checkout of the git repository works. Either it was a server hickup on our side and it is working again or the server is blocked maybe by a firewall or something like that on your side. But if you can, you should install from debian packages anyway. The reason why that didn't work for you is that your package name was incorrect. Try:

sudo apt-get install ros-fuerte-client-rosjava-jni
edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2012-11-01 09:50:07 -0500

Seen: 262 times

Last updated: Nov 01 '12