Ask Your Question
4

Error when installing IPC Bridge for ROS and MatLAB

asked 2012-10-14 14:42:19 -0500

josemscnogueira gravatar image

updated 2014-01-28 17:13:55 -0500

ngrennan gravatar image

I'm trying to install IPC Bridge using a step-by-step guide from this link: https://alliance.seas.upenn.edu/~meam620/wiki/index.php?n=Roslab.IpcBridge#Installation

After compiling ipc_bridge_ros (rosmake ipc_bridge_ros) and compiling the first message folder (roscd ipc_roslib && make), I'm getting error messages for the remaining folders.

$ roscd ipc_std_msgs && make

std_msgs_Bool_publisher.cc:(.text._ZN3ros13serialization10SerializerIhE4readINS0_7IStreamEEEvRT_Rh[void ros::serialization::Serializer<unsigned char="">::read<ros::serialization::istream>(ros::serialization::IStream&, unsigned char&)]+0x3a): undefined reference to `ros::serialization::throwStreamOverrun()' collect2: ld returned 1 exit status make: * [std_msgs_Bool_publisher] Error 1

How may I solve this problem?

edit retag flag offensive close merge delete

Comments

1

It worked for me with Electric, but now I have the same problem with Fuerte and Ubuntu 12.04. Any suggestions? Anybody?

jjamp gravatar image jjamp  ( 2012-10-17 08:49:43 -0500 )edit

3 Answers

Sort by ยป oldest newest most voted
4

answered 2012-10-22 09:15:46 -0500

jjamp gravatar image

updated 2012-10-22 09:16:31 -0500

Probably not a nice solution but it works for me: Change the last line in ipc_bridge_ros.mk to

$(CXX) -I./include $(ROS_CXXFLAGS) $(IPC_BRIDGE_CXXFLAGS) -lstdc++ $(IPC_LFLAGS) -lipc $(ROS_LFLAGS) $(ROS_LIBS) $^ -o bin/$@ -lroscpp -lrosconsole -lroscpp_serialization -lipc
edit flag offensive delete link more
0

answered 2012-12-03 20:32:15 -0500

gurenko gravatar image

Sory, but how did you do it?

edit flag offensive delete link more

Comments

Sorry for the delay, but I wasn't here for a long time. I updated my answer above.

FTrommsdorff gravatar image FTrommsdorff  ( 2013-01-14 03:45:04 -0500 )edit
-1

answered 2012-11-08 02:07:43 -0500

FTrommsdorff gravatar image

updated 2013-01-14 03:49:14 -0500

Sorry, this is not an answer, but I stuck at the same procedure. My problem occurs, when I try to compile the first message folder (roscd ipc_roslib && make). The output message is:

[ rosmake ] rosmake starting...                                                 
[ rosmake ] Packages requested are: ['ipc_bridge_ros']                          
[ rosmake ] Logging to directory <my_dir>/.ros/rosmake/rosmake_output-20121108-150035
[ rosmake ] Expanded args ['ipc_bridge_ros'] to:
['ipc_bridge_ros']             
[rosmake-1] Starting >>> ipc [ make ]                                           
[rosmake-0] Starting >>> roslang [ make ]                                       
[rosmake-2] Starting >>> geometry_msgs [ make ]                                 
[rosmake-2] Finished <<< geometry_msgs  No Makefile in package geometry_msgs    
[rosmake-0] Finished <<< roslang  No Makefile in package roslang                
[rosmake-2] Starting >>> sensor_msgs [ make ]                                   
[rosmake-0] Starting >>> roscpp [ make ]                                        
[rosmake-3] Starting >>> nav_msgs [ make ]                                      
[rosmake-2] Finished <<< sensor_msgs  No Makefile in package sensor_msgs        
[rosmake-0] Finished <<< roscpp  No Makefile in package roscpp                  
[rosmake-3] Finished <<< nav_msgs  No Makefile in package nav_msgs              
[rosmake-1] Finished <<< ipc [PASS] [ 0.83 seconds ]                            
[rosmake-1] Starting >>> ipc_bridge [ make ]                                    
[rosmake-1] Finished <<< ipc_bridge  No Makefile in package ipc_bridge          
[rosmake-1] Starting >>> ipc_bridge_ros [ make ]                                
[rosmake-1] Finished <<< ipc_bridge_ros  No Makefile in package ipc_bridge_ros  
[ rosmake ] Results:                                                            
[ rosmake ] Built 8 packages with 0 failures.                                   
[ rosmake ] Summary output to directory                                         
[ rosmake ] <my_dir>/.ros/rosmake/rosmake_output-20121108-150035

I guess, that the folder ipc_msgs is not at the right place (I did not see an intruction for that, thus I placed it into the ipc_bridge_stack folder, which is agained placed into the ROS package/stack folder).

EDIT:

When compiling the message folder, an error similar to "unknown command "mex"" could appear. This happens, when the matlab command "mex" is not available in the environment variable "PATH". To do so, use the following line in your .bashrc script:

export PATH=<your path="" to="" matlab="">/bin:$PATH

With it, you should be able to call the mex command from anywhere in the shell.

edit flag offensive delete link more

Comments

My problem above was solved - had to make the "mex"-command available to the environment.

FTrommsdorff gravatar image FTrommsdorff  ( 2012-11-08 03:34:42 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2012-10-14 14:42:19 -0500

Seen: 1,017 times

Last updated: Jan 14 '13