Ask Your Question
0

Running turtlebot on a roomba, launch file?

asked 2012-10-10 12:43:05 -0500

krst gravatar image

updated 2012-10-15 03:29:25 -0500

I have a roomba 780 that I am trying to run turtlebot on. I have been able to install the turtlebot fuerte on the both pc and I can ssh into the turtlebot computer, so all communication parts are set and are working. But when I start the turtlebot nothing happens , I can start the turtlebot service so it run but i cant comunicate with my roomba. I think i know/have read that you have to change the communication speed and also tell in the launch file that you have a roomba and that it has no gyro.

However I have no clue how to change the launch file. I have done the basic tutorials, but still not getting how I create or edit the launch file?! Some help or guidance to where on the forum i find this info would be very appreciated

Thanks

edit retag flag offensive close merge delete

Comments

Many thanks Lorenz, I am still however little confused where to put and create the launch file? Because when i tried to edit the launch file in the etc/ros folder it was write protected the folder and file. I assume I am doing this completly wrong the launch file creation?

krst gravatar image krst  ( 2012-10-11 00:26:22 -0500 )edit
1

Just put the launch file somewhere and execute it with roslaunch. Make sure that no other turtlebot related stuff is running to avoid conflicts.

Lorenz gravatar image Lorenz  ( 2012-10-11 04:04:41 -0500 )edit

I am seeing that I get the error message [Distance, angle displacement too big, invalid readings from robot. Distance: 1.84, Angle: -21.02]. I have a memory that i have seen this here before on the forum but cant find the post... When i look at the node.py this error message I thought only would come for a create?

krst gravatar image krst  ( 2012-10-14 01:22:58 -0500 )edit

Please do not delete a complete question and replace it by a new question to not lose the connection between questions and answers. Instead, please create a new question.

Lorenz gravatar image Lorenz  ( 2012-10-14 22:09:50 -0500 )edit

Ok sorry, I saw it as an extentions of the same topic but I will edit back and do that instead! Thanks!

krst gravatar image krst  ( 2012-10-15 03:29:02 -0500 )edit

I think it's just important to keep the old question. If you want, you can of course edit it and add further information. But in case you have a separate, although maybe related question, I guess it's better to open a new question. That's what this site is all about in the end :)

Lorenz gravatar image Lorenz  ( 2012-10-15 04:50:31 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted
1

answered 2012-10-10 23:10:42 -0500

Lorenz gravatar image

I am not sure how different the communication protocols between the roomba 780 and the roomba 530 are. You could try the following launch file to bring up the robot's base driver:

<launch>
  <node name="turtlebot_node" type="turtlebot_node.py" pkg="turtlebot_node">
    <rosparam>
      port: /dev/ttyUSB0
      publish_tf: True
      robot_type: roomba
      has_gyro: False
    </rosparam>
  </node>
</launch>

Make sure that the usb port is correct. If launching the file does not throw an error, rostopic echo /odom should publish data and you should be able to teleop the robot. If you are getting errors, I guess the communication protocol changed. In that case you might have to patch the turtlebot driver. Patches welcome :)

edit flag offensive delete link more
0

answered 2012-10-19 15:15:02 -0500

krst gravatar image

updated 2012-10-19 15:16:09 -0500

Many thanks for the help Lorenz!

After trying several times, reinstall of ubuntu and turtlebot, at last I got it working. Actually I use the roslaunch file you suggested, the problem is that the startup of the turtlebot is intermittent. I need several times to get it to start, and even then I will always get see several error messages. However, as long as the message is not that the create is not connect error but some other error message normally it is possible then to go into teleop even thought it says in the terminal after running roslaunch that the machine have failed and will exit.

I have asked irobot for specifications of the 780 but they say that they did not want to give me that information. I have run the 780 now through a serial prompt with the OI of the 500 and all appears to be the same.

I will now try to get it working with the kinect and see if i can manage to do some mapping at last!

If someone wants/can help me to close this question i would appreciate that, I don't have enough "reputation" to do that!

Thanks!

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2012-10-10 12:43:05 -0500

Seen: 740 times

Last updated: Oct 19 '12