ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question
2

3DConnexion SpaceNavigator installation problem

asked 2012-10-10 05:52:27 -0500

Makus Noack gravatar image

updated 2014-01-28 17:13:54 -0500

ngrennan gravatar image

Hello, I am on ROS electric with Ubuntu 11.10 and tried to setup my SpaceNavigator with this tutorial.

But when I type in the command "sudo ./spacenavd -d" it does not recognize my device:

Console output:

Spacenav daemon svn-r87
failed to open config file /etc/spnavrc: No such file or directory. using defaults.
using device: /dev/input/event9
Wrong device, no relative events reported!

I tried different USB ports, and when the device is not connected it says "no spaceball found". So it is seeing the device, but does not recognize it correctly.

Has anyone an idea what I could do?

Thanks, Regards Markus

edit retag flag offensive close merge delete

Comments

What product are you trying to use?

jbohren gravatar image jbohren  ( 2012-10-10 08:56:24 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
2

answered 2012-10-11 10:04:20 -0500

Makus Noack gravatar image

updated 2012-10-11 10:04:53 -0500

Ah i solved the problem by installing "spacenavd" in Ubuntu Software Center. This is a newer revision of the driver. I use the "SpaceNavigator" product from 3DConnexion

edit flag offensive delete link more

Question Tools

Stats

Asked: 2012-10-10 05:52:27 -0500

Seen: 1,210 times

Last updated: Oct 10 '12