Ask Your Question
0

openni_audio for Xtion Pro Live

asked 2012-10-09 16:15:03 -0500

Quang Nguyen gravatar image

updated 2012-10-09 16:15:25 -0500

Hi all,

I am trying to use two microphones of Xtion Pro Live sensor for my research. I found a package openni_audio here, https://kforge.ros.org/openni/openni_audio

After remove line #9 (<depend package="openni"/>) in manifest.xml file (I cannot find any package named as "openni"), I can make the package. However, I don't know how to run/launch the node because there is no launch file.

Can anybody can share your experience with this node?

To Mr. Micheal Ferguson, thank for your code. But could you share more?

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2012-10-15 21:09:47 -0500

fergs gravatar image

updated 2012-10-15 21:11:32 -0500

This is highly experimental code that just barely works -- really more a proof of concept than anything else. ROS doesn't have much in the way of audio support and so you won't find much that works with the output of this node (there is an example script in Python which might happen to play audio using the 'ao' library).

That said, this is designed to be a nodelet that you would add to your normal openni launch file. It would look something like:

<node pkg="nodelet" type="nodelet" name="driver" 
       args="load openni_audio/AudioNodelet $(arg manager) $(arg bond)"
       respawn="$(arg respawn)">
    <param name="channel" value="0" />
 </node>

if you were to add it directly to the openni launch files. The important parameter is 'channel' which specifies which microphone to connect to. If you want to connect to both sides, you would spawn two nodelets, each serving a different channel.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2012-10-09 16:15:03 -0500

Seen: 356 times

Last updated: Oct 15 '12