Ask Your Question
1

Roboearth OpenCV Error

asked 2012-10-01 03:40:53 -0500

yigit gravatar image

I haven't been able to save models using re_object_record record_gui in the roboearth stack.

I am using ubuntu 12.04 and ros-fuerte.

I am recording the objects without any errors, but when I click on save button, I get the following error

OpenCV Error: The function/feature is not implemented (OpenCV was built without SURF support) in cvExtractSURF, file /tmp/buildd/ros-fuerte-opencv2-2.4.2-0precise-20120908-1624/modules/legacy/src/features2d.cpp, line 77
caught exception
result = false

By looking at a similar question here, I guess that this error might be resolved by linking the correct version of the library, namely libopencv_nonfree.so

I am stuck at this point. Do I really need to link opencv nonfree library? If so, how do I link it?

Thanks in advance.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
2

answered 2012-10-01 21:49:57 -0500

ddimarco gravatar image

Sorry about that, please run "svn up" and try it again.

edit flag offensive delete link more

Comments

Thanks ddimarco, this will solve the SURF problem I suppose. I cannot compile the re_vision however, some declarations in the headers are missing. Here is a screenshot http://i.imgur.com/MzpZh.jpg . I declared getNumberOfPoints() in PatchFile.h, then some warnings and errors emerged.

yigit gravatar image yigit  ( 2012-10-01 23:20:05 -0500 )edit

Please try it again now :)

ddimarco gravatar image ddimarco  ( 2012-10-01 23:52:16 -0500 )edit

Okay, thanks again. It's working now

yigit gravatar image yigit  ( 2012-10-02 01:48:43 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2012-10-01 03:40:53 -0500

Seen: 414 times

Last updated: Oct 01 '12