Ask Your Question
1

Is it possible to get navigation 1.10.1?

asked 2012-09-30 22:50:01 -0500

ChengXiang gravatar image

Hi, i am a beginner and is using the navigation stack for my school project. The function that I am interested in is the base_local_ planner. On its web page section 4 generic local planning, it is mentioned that it is possible to create custom local planner. However, this is only for release 1.10.1. But I can't get navigation 1.10.1, even after running apt-get update. (mine is 1.8.3, after checking the Cmakelist). May i know if navigation 1.10.1 is out yet? If so how can i get it?

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
3

answered 2012-10-01 00:26:52 -0500

KruseT gravatar image

updated 2012-10-01 01:21:23 -0500

The nav stack did change in that respect, so if you can, you should use the new code. The new classes as shown on that wiki page make it easier for you to create a custom local planner.

You can use the sources for 1.9/1.10 with ros 1.8 as well, the APIs did not change.

And to get it, just download the sources.

$ hg pull https://kforge.ros.org/navigation/navigation

will get you the sources, if you use rosws, you can do

$ roslocate info navigation 
- hg:
    local-name: navigation
    meta:
      repo-name: rosdistro_fuerte
    uri: https://kforge.ros.org/navigation/navigation
    version: navigation-1.8

Copy this to your rosinstall file replacing version navigation-1.8 with navigation-1.9.1

Another way to do this is to call

$ rosws set navigation --hg https://kforge.ros.org/navigation/navigation --version=navigation-1.9.1
edit flag offensive delete link more

Comments

Thank you. Let me try it out.

ChengXiang gravatar image ChengXiang  ( 2012-10-05 05:39:33 -0500 )edit
1

answered 2012-09-30 22:56:10 -0500

Lorenz gravatar image

What's wrong with using 1.8.3? Did you try it? I think the nav stack didn't really change so using the current version shouldn't be a problem.

edit flag offensive delete link more

Comments

No. 1.8.3 is working fine. Just that on the web page, it is mentioned that the generic local planning is new in 1.10.1. So if i want to create a custom local planner, is it possible to do so on 1.8.3?

ChengXiang gravatar image ChengXiang  ( 2012-09-30 23:10:52 -0500 )edit

Sure. It should work in 1.8.3, too.

Lorenz gravatar image Lorenz  ( 2012-09-30 23:12:48 -0500 )edit

Thanks. i will try it out.

ChengXiang gravatar image ChengXiang  ( 2012-09-30 23:23:55 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2012-09-30 22:50:01 -0500

Seen: 63 times

Last updated: Oct 01 '12