Ask Your Question
0

ROS Fuerte snags on OSX Lion

asked 2012-09-27 05:58:28 -0600

ee05073 gravatar image

updated 2012-09-28 03:14:03 -0600

So I think I was finally able to install ROS Fuerte on Mac which cannot easily be accomplished by following religiously the tutorial in there as it keeps on hitting snags. Here are some error resolutions, which I'm not sure they are the optimal ones, maybe someone would like to confirm since I want to install UWSim but I cannot, which could be because of the osx not being ready for it:

rosdep install UWSim ERROR: the following packages/stacks could not have their rosdep keys resolved to system dependencies: UWSim: No definition of [libopenscenegraph] for OS [osx]

RESOLUTIONS

So open up your Terminal and put up aside the ROS installation tutorial I will try to follow up the problems as they emerge on the screen.

1) Right up from the beginning, the tutorial asks to write lines to your .bashrc file which is fine, except terminal each time you close and re-open a window is not calling this file, and yes I did go to Terminal > preferences > shell opens with: comand /bin/bash

So what I did was to write in .profile source ~/.bashrc which seems to solve this question, I saw in here that OS X doesn't read .bashrc file on bash start. Instead, it reads the following files (in the following order):

  1. /etc/profile
  2. ~/.bash_profile
  3. ~/.bash_login
  4. ~/.profile

2) If for any reason one of the instructions fails to install because of denied permissions as it will probably do on easy_install pip, one can "force" it by adding sudo before it.

3) When you are installing dependencies, log4cxx and swig-wx will turn into a headache.

i)Actually with this one I was not pleased with my solution but as I dug up on github comunity I could not find the proper solution. It snags in

system './autogen.sh'

and it fails to install log4cxx. What I did here was comment this line on the formula (/usr/local/Library/Formula/log4cxx.rb) and it seems to install fine but I'm unsure of it.

ii)Actually swig-wx was updated by Homebrew so if it fails to install just do the command again and it installs fine. If not go to this site which helped me before.

4) Next when it will probably fail to run the instruction make -j8... This has to do with the boost dependency. I could not figure out why but I downgraded it (boost 1.50.0 to boost 1.49.0) and then it'll work:

brew uninstall 
boost pushd $(brew --prefix) 
git checkout -f bf4f9aa Library/Formula/boost.rb 
popd 
brew install -v boost

5) It is quite confusing (and I still am a bit confused!!!) about the paths used to install the libraries. While it reads on the tutorial installation to send the files to /opt/ros/fuerte, usually the commands come up with ~/ros which will send you the files to the User. If you have installed ros-underlay to /opt/ros/fuerte, you should do the Desktop Full-Install on ... (more)

edit retag flag offensive close merge delete

Comments

Hopefully some of these issues will get solved in the next version of ROS. The pre-release is supposed to come out Oct 15.

Kevin gravatar imageKevin ( 2012-09-27 12:26:59 -0600 )edit

This is all useful information, so for any problem you can narrow down, you should add an entry in the troubleshooting section and/or updated the installation instructs where appropriate.

WilliamWoodall gravatar imageWilliamWoodall ( 2012-09-28 07:06:59 -0600 )edit

2 Answers

Sort by ยป oldest newest most voted
0

answered 2012-09-28 03:17:57 -0600

ee05073 gravatar image

About log4cxx this is was what happened

brew install log4cxx
==> Downloading http://www.apache.org/dyn/closer.cgi?path=logging/log4cxx/0.10.0/apach
==> Best Mirror http://mirrors.fe.up.pt/pub/apache/logging/log4cxx/0.10.0/apache-log4c
######################################################################## 100.0%
==> ./autogen.sh
./autogen.sh: line 23: glibtoolize: command not found
./autogen.sh: line 27: aclocal: command not found
./autogen.sh: line 28: autoconf: command not found
./autogen.sh: line 29: automake: command not found

Error: log4cxx did not build
Logs: /Users/GCCS/Library/Logs/Homebrew/log4cxx/
Help: https://github.com/mxcl/homebrew/wiki/troubleshooting
edit flag offensive delete link more

Comments

This is a Homebrew problem, it should go into an issue on Homebrew's github.com site. It might have to do with your system, I can install log4cxx fine.

WilliamWoodall gravatar imageWilliamWoodall ( 2012-09-28 07:04:39 -0600 )edit

Do you have libtool and the other commands installed from homebrew?

Kevin gravatar imageKevin ( 2012-09-28 15:29:24 -0600 )edit

Yes, I have also tried to install it but it is the same output

ee05073 gravatar imageee05073 ( 2012-09-29 07:11:59 -0600 )edit
0

answered 2012-09-27 12:24:12 -0600

Kevin gravatar image

Agree ... it takes a certain kind of person to install ROS on OSX ... it is not for the timid :)

1) I always modify /etc/profile ... I am the only one that uses my Mac

2) If you change the permissions for the python directories, you shouldn't need to do sudo. However, once you do sudo, your stuck with it until you fix the permissions again.

3) installing log4cxx through homebrew was no problem for me ... what were your issues, I don't understand.

4) yes, boost 1.50 is a known issue

5) agree ... the "new" ROS layout is confusing. Why the example install commands show ~/ros in them is silly IMHO. I don't like the way they have hard coded /opt/ros/... into things. Pre-fuerte, I would install ROS into /usr/local/ros like I do with homebrew and it worked fine.

6) things must have changed since I last installed that ... I didn't have any issues before.

7) yes, you have to make sure your env is setup correctly and I do have gsed installed, but I have not linked it like you and haven't had any issues. Also, was "(lauras topic)" supposed to be linked to something???

edit flag offensive delete link more

Comments

Yes, lauras topic is now linked to the post I saw that

ee05073 gravatar imageee05073 ( 2012-09-28 03:16:24 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2012-09-27 05:58:28 -0600

Seen: 341 times

Last updated: Sep 28 '12