Ask Your Question
1

unable to get point cloud from /camera/depth/points in rviz

asked 2012-09-23 09:18:13 -0500

trailblazer19 gravatar image

updated 2012-09-23 10:45:28 -0500

Eric Perko gravatar image

I did :

rostopic echo /camera/depth/points

it seems topic is publishing messages. However, when i launch rviz- setting fixed frame to /camera_link or /camera_depth_frame or /camera_depth_optical_frame ( tried all seprately)

i get the following error when i subscribe to /camera/depth/points:

Transform= For frame [/openni_rgb_optical_frame]: Frame [/openni_rgb_optical_frame] does not exist

Any ideas on what am i doing wrong here ?

Also, point cloud data from /camera/depth_registered/points is currently displayed.

edit retag flag offensive close merge delete

Comments

Could you include the roslaunch command you are using to start up the driver?

Eric Perko gravatar image Eric Perko  ( 2012-09-23 10:46:30 -0500 )edit

roslaunch openni_camera openni_node.launch

trailblazer19 gravatar image trailblazer19  ( 2012-09-27 11:09:37 -0500 )edit

@Boris - i ran the echo frame_id command and got back /openni_rgb_optical_frame . I manually entered it in the Fixed frame under Global Options but it gives me frame does not exist error.

trailblazer19 gravatar image trailblazer19  ( 2012-09-27 11:17:34 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
1

answered 2012-09-23 16:28:28 -0500

When OpenNI publishes point cloud it sets up frame_id to some prespecified value, but it does not create a real tf frame. The frame_id simply says that points were acquired with respect to that frame.

To check the frame_id of your point cloud use the following command:

$ rostopic echo -n 1 /camera/depth/points/header/frame_id

Then, either manually fill in the value you get to Fixed frame in RViz or define a new tf transformation with static_transform_publisher, for example:

$ rosrun tf static_transform_publisher 0 0 0 0 0 0 /world /openni_rgb_optical_frame 100
edit flag offensive delete link more

Comments

I did what you said but i still dont get a display on RVIZ, i still get the error For frame [/openni_rgb_optical_frame]: Fixed Frame [/openni_rgb_optical_frame ] does not exist

ctguell gravatar image ctguell  ( 2013-06-17 13:56:59 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2012-09-23 09:18:13 -0500

Seen: 3,653 times

Last updated: Sep 23 '12