ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

[SKIP] No rule to make target None

asked 2012-09-18 03:47:33 -0500

Benoit Larochelle gravatar image

updated 2012-09-19 03:04:54 -0500

I have a problem that appeared overnight. All of my code is on an SVN and used to compile fine. This morning, I started getting this problem when compiling some packages:

[SKIP] No rule to make target None

I did not use the computer for about ten days because I was at a conference, but it was off so no updates were applied since the last time that I used it.

So here is what I tried.

roscreate-pkg foo
rosmake foo

And I got the same problem:

[ rosmake ] rosmake starting...                                                                                                          
[ rosmake ] Packages requested are: ['foo']                                                                                              
[ rosmake ] Logging to directory /home/robot/.ros/rosmake/rosmake_output-20120918-154406                                                 
[ rosmake ] Expanded args ['foo'] to:
[rosmake-0] Starting >>> foo [ make ]                                                                                                    
[rosmake-0] Finished <<< foo [SKIP] No rule to make target None                                                                          
[ rosmake ] Results:                                                                                                                     
[ rosmake ] Built 1 packages with 0 failures.                                                                                            
[ rosmake ] Summary output to directory                                                                                                  
[ rosmake ] /home/robot/.ros/rosmake/rosmake_output-20120918-154406

I then applied all Ubuntu updates for 12.04, including all updates for ROS Fuerte. I created package foo2 and I still have the same problem. In my own packages, it seems like the build starts, but does not finish, because the ROS messages are not generated.

edit retag flag offensive close merge delete


Are the packages in the ROS_PACKAGE_PATH?

dornhege gravatar image dornhege  ( 2012-09-18 05:25:34 -0500 )edit

Yes, everything is in ROS_PACKAGE_PATH. roscd and rospack find work perfectly. By creating a new package foo, I wanted to ensure that it was not a dependency problem.

Benoit Larochelle gravatar image Benoit Larochelle  ( 2012-09-18 21:54:46 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted

answered 2012-09-18 23:24:30 -0500

Benoit Larochelle gravatar image

In the end, I uninstalled ROS with

sudo apt-get remove ros-fuerte-*
sudo apt-get autoremove ros-fuerte-*

Then, I rebooted, re-installed ROS, and everything is fine again.

edit flag offensive delete link more


Same thing happened to me with a fresh install of groovy. It turned out some nasty stuff actually happened to my environment variables ( file ".bashrc" being damaged). You can check the variable ROS_PACKAGE_PATH is correctly set by running "export" in a terminal. It displays all variables defined.

anonymous userAnonymous ( 2013-01-14 05:30:02 -0500 )edit

answered 2012-09-18 09:34:30 -0500

Hi Benoit, in cases were you migrated (e.g. from diamond/electric to fuerte) you need do ensure that your CMakeFiles/Caches and co are removed. They contain paths to the used ROS-Version, i.e. paths to older versions which are not any longer available on your system.

Try rosmake --pre-clean or even better inside the package in question try rm -r CMakeFiles cmake_install.cmake CMakeCache.txt && rosmake

edit flag offensive delete link more


Yes, I already tried that, but in vain. My installation of Ubuntu 12.04 is recent and it only ever had ROS Fuerte.

Benoit Larochelle gravatar image Benoit Larochelle  ( 2012-09-18 21:57:28 -0500 )edit

Question Tools

1 follower


Asked: 2012-09-18 03:47:33 -0500

Seen: 1,915 times

Last updated: Sep 19 '12