Ask Your Question
1

Adjusting the default clipping distance on Gazebo

asked 2012-09-17 15:00:34 -0500

pyrobat gravatar image

I have a large world file, and unfortunately the default clipping distance (in UserCamera.cc) is set such that I cannot view my entire world on screen. So far, I have worked around this by:
1. Deleting the ROS_NOBUILD in the gazebo folder located in /opt/ros/fuerte/stacks/simulator_gazebo
2. Performing a '$rosmake gazebo' as root
3. Modifying the UserCamera.cc
4. Doing a '$make', '$make install', and '$ldconfig' as root in the appropriate build folder to propagate the changes.
While this worked on prior gazebo releases, with the newest gazebo release (1.6.16) the GAZEBO_RESOURCE_PATH does not seem to be set correctly after going through this process. Besides, I would like to not have to mess around with a rosmake of gazebo (which I know is ill advised) so an alternative solution would be welcome.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2012-11-04 13:46:40 -0500

SL Remy gravatar image

Have you tried modifying the farClip and the horizontal field of view?

e.g.

<hfov>90</hfov>
<nearClip>0.01</nearClip>
<farClip>100</farClip>

From test_camera.urdf

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2012-09-17 15:00:34 -0500

Seen: 114 times

Last updated: Nov 04 '12