ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | Q&A
Ask Your Question

Rosmake error with package csm

asked 2012-09-13 20:04:57 -0500

Cyprien gravatar image


I'm trying to install the scan_tools library with rosmake. However I have an error when it build the csm package (if I rosmake the other package it works)

Here the error I get:

[ rosmake ] rosmake starting...                                                                                                                                            
[ rosmake ] Packages requested are: ['csm']                                                                                                                                
[ rosmake ] Logging to directory /home/cyprien/.ros/rosmake/rosmake_output-20120914-112111                                                                                 
[ rosmake ] Expanded args ['csm'] to:
[rosmake-0] Starting >>> csm [ make ]                                                                                                                                      
[ rosmake ] All 32 linessm: 0.9 sec ]                                                                                                             [ 1 Active 0/1 Complete ]
  mkdir -p build
  if [ ! -f csm-git-23703a998fff57250322.tar.gz.md5sum ]; then echo "Error: Couldn't find md5sum file csm-git-23703a998fff57250322.tar.gz.md5sum" && false; fi
  `rospack find rosbuild`/bin/ build/csm-git-23703a998fff57250322.tar.gz `awk {'print $1'} csm-git-23703a998fff57250322.tar.gz.md5sum`
  [rosbuild] Downloading to build/csm-git-23703a998fff57250322.tar.gz...Traceback (most recent call last):
    File "/opt/ros/fuerte/share/ros/core/rosbuild/bin/", line 58, in <module>
    File "/opt/ros/fuerte/share/ros/core/rosbuild/bin/", line 30, in main
      urllib.urlretrieve(uri, dest)
    File "/usr/lib/python2.7/", line 93, in urlretrieve
      return _urlopener.retrieve(url, filename, reporthook, data)
    File "/usr/lib/python2.7/", line 239, in retrieve
      fp =, data)
    File "/usr/lib/python2.7/", line 207, in open
      return getattr(self, name)(url)
    File "/usr/lib/python2.7/", line 436, in open_https
    File "/usr/lib/python2.7/", line 954, in endheaders
    File "/usr/lib/python2.7/", line 814, in _send_output
    File "/usr/lib/python2.7/", line 776, in send
    File "/usr/lib/python2.7/", line 1161, in connect
      self.sock = ssl.wrap_socket(sock, self.key_file, self.cert_file)
    File "/usr/lib/python2.7/", line 381, in wrap_socket
    File "/usr/lib/python2.7/", line 143, in __init__
    File "/usr/lib/python2.7/", line 305, in do_handshake
  IOError: [Errno socket error] [Errno 1] _ssl.c:504: error:140770FC:SSL routines:SSL23_GET_SERVER_HELLO:unknown protocol
[ rosmake ] Output from build of package csm written to:
[ rosmake ]    /home/cyprien/.ros/rosmake/rosmake_output-20120914-112111/csm/build_output.log                     
[rosmake-0] Finished <<< csm [FAIL] [ 0.89 seconds ]                                                                                                                       
[ rosmake ] Halting due to failure in package csm. 
[ rosmake ] Waiting for other threads to complete.                                                                     
[ rosmake ] Results:                                                                                                                                                       
[ rosmake ] Built 1 packages with 1 failures.                                                                                                                              
[ rosmake ] Summary output to directory                                                                                                                                    
[ rosmake ] /home/cyprien/.ros/rosmake/rosmake_output-20120914-112111

I tried to go into to see what's going on, and it seems to be a problem of mismatch md5sum, but I'm not sure.

Thanks for your help

Cyprien Descheemaeker

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted

answered 2012-09-16 19:39:09 -0500

Cyprien gravatar image

updated 2012-09-16 19:40:27 -0500

Problem solved : I just downloaded the tar file in scan_tools/csm/build, and relaunch the rosmake

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools


Asked: 2012-09-13 20:04:57 -0500

Seen: 515 times

Last updated: Sep 13 '12