Ask Your Question
0

scan_tools runtime error undefined symbol cblas_dtrsv ubuntu 12.04.2LTS

asked 2013-03-05 22:00:42 -0500

micmac gravatar image

updated 2014-01-28 17:15:32 -0500

ngrennan gravatar image

I have downloaded the scan_tools source code from git: it did build successfully, but at runtime I get:

"laser_scan_matcher_node: symbol lookup error: /usr/lib/libgsl.so.0: undefined symbol: cblas_dtrsv".

When I run ldd on the laser_scan_matcher_node binary, I see that libgsl.so.0 is linked, but NOT libgslcblas.

I am on ubuntu 12.04.2LTS.

What could I do to make it work, please ?

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2013-03-06 21:33:59 -0500

micmac gravatar image

By browsing the web, I have found a way to build it on ubuntu 12.04.2.LTS. In fact only the laser_scan_matcher triggers the symbol lookup error.

STEPS:

1) rosmake scan_tools

2) sudo apt-get remove binutils-gold (this one doesn't link libgslcblas correctly, as stated on this page: http://stackoverflow.com/questions/14405601/gnu-scientific-library-cblas-symbol-lookup-error ).

3) rosmake --pre-clean laser_scan_matcher : the build will not finish correctly (problems with libboost),but next step will finish the build:

4) sudo apt-get install binutils-gold

5) rosmake laser_scan_matcher : the build finishes successfully.

This time when I run "ldd laser_scan_matcher_node" on the binary, libgslcblas is linked correcly, and the laser_scan_matcher works :)

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2013-03-05 22:00:42 -0500

Seen: 322 times

Last updated: Mar 06 '13