Error in scan matching. ICP failed for some reason. [closed]

asked 2012-09-13 19:16:58 -0500

Astronaut gravatar image

Hello

I have a bit problems with the amcl. When Im running the amcl node have problems with the localisation. I got an scan matching error saying:

: before trimming, only 0 correspondences.

icp: ICP failed for some reason. These are the amcl parameters

<

node pkg="amcl" type="amcl" name="amcl" respawn="true" output="screen">
        <param name="base_frame_id" value="base_link"/>
        <param name="odom_frame_id" value="world"/>
        <param name="global_frame_id" value="map"/>
        <param name="update_min_d" value="0.2"/>   
        <param name="update_min_a" value="0.5"/> 
        <param name="initial_pose_x" value="1.65"/>
        <param name="initial_pose_y" value="-1.28"/>
        <param name="initial_pose_a" value="-1.65"/>
        <param name="min_particles" value="5000"/> 
        <param name="max_particles" value="8000"/>
        <param name="odom_model_type" value="diff"/>
        <param name="kld_err" value="0.01"/> 
        <param name="resample_interval" value="1"/>
        <param name="odom_alpha1" value="0.2"/>   
        <param name="odom_alpha2" value="0.2"/>
        <param name="odom_alpha3" value="0.5"/>
        <param name="odom_alpha4" value="0.5"/>
        <param name="laser_max_beams" value="30"/>
    </node>

Any help?

Thanks

edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by tfoote
close date 2015-04-05 16:15:58.698294

Comments

did you find any solution to this ?

sj haque gravatar imagesj haque ( 2013-03-10 07:53:59 -0500 )edit