Ask Your Question
1

Turtlebot 2D Nav Goal not working

asked 2012-09-12 08:57:29 -0600

Aroarus gravatar image

I am running the turtlebot navigation demo in fuerte and 12.04 Precise. Everything works fine up until I try and set a nav goal in rviz, then nothing happens. The console output says that a goal is being set, but the turtlebot does not move and no messages are sent on move_base_simple/goal. I am using the versions of rviz and the demos directly from the repositories with no modifications. Does anyone know why this might be happening?

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
0

answered 2012-09-12 10:01:28 -0600

ahendrix gravatar image

It sounds like you don't have the proper goal topic configured in rviz.

In particular, you should set the 2D Nav Toal topic to /move_base_simple/goal in the Tool Properties window.

Take a look at http://ros.org/wiki/navigation/Tutorials/Using%20rviz%20with%20the%20Navigation%20Stack

edit flag offensive delete link more

Comments

Unfortunately, I have that set properly already in rviz. When using rostopic echo to listen to the "move_base_simple/goal" topic however, nothing gets sent when I use the "2D Nav Goal" button in RViz. Also nothing gets sent when I hit the "2D Pose Estimate" button and listen to "initialpose"

Aroarus gravatar imageAroarus ( 2012-09-13 07:48:32 -0600 )edit

Are you running ROS over a network? Which machine are you running 'rostopic echo' on?

ahendrix gravatar imageahendrix ( 2012-09-13 08:42:08 -0600 )edit

I am running ROS between two computers over my lab wireless network. I have tried running rostopic echo on both the workstation and the mobile computer, with the same result.

Aroarus gravatar imageAroarus ( 2012-09-17 09:43:27 -0600 )edit

I would walk through the network setup and make sure everything there is in order: http://www.ros.org/wiki/ROS/NetworkSetup

ahendrix gravatar imageahendrix ( 2012-09-17 11:19:53 -0600 )edit

Have you checked your frames.pdf file ? You can check the transforms that are published. Please type below command on another terminal and frames.pdf file will be generated: rosrun tf view_frames

Devasena Inupakutika gravatar imageDevasena Inupakutika ( 2013-03-23 07:07:00 -0600 )edit

You should get a tree like the following link --> /map -> /odom -> base_link -> openni_camera. If anyone link is missing, turtlebot won't move and you get warning that particular link is not found. Hope this helps !!

Devasena Inupakutika gravatar imageDevasena Inupakutika ( 2013-03-23 07:09:11 -0600 )edit
1

answered 2015-06-13 02:21:56 -0600

Castlespike gravatar image

Check turtlebot_teleop keyboard_teleop is running on your computer. I had same problem with you but when i killed console controler node, turtlebot moved to the goal.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2012-09-12 08:57:29 -0600

Seen: 3,139 times

Last updated: Sep 12 '12