Ask Your Question
0

Rgbdslam installation error

asked 2012-09-09 07:17:08 -0500

SHPOWER gravatar image

updated 2014-01-28 17:13:36 -0500

ngrennan gravatar image

Hi guys,

I am new in ROS. I am trying to install rgbdslam on my laptop. I have got a following error: '/usr/bin/ld: cannot find -lGL' and later I have got 'SiftGPU cannot be compiled. Returned: 2'.

What should I do? help me please.

Thanks in advance

edit retag flag offensive close merge delete

2 Answers

Sort by ┬╗ oldest newest most voted
1

answered 2012-09-09 21:50:07 -0500

Sudhan gravatar image

updated 2012-09-10 22:09:07 -0500

Install all this before building the package rgbdslam,

sudo apt-get install libglew1.5-dev libdevil-dev libsuitesparse-dev libgsl0-dev.

Have you built g2o package?

I think the problem is with openGL. So, try

sudo apt-get install libglu1-mesa-dev freeglut3-dev freeglut3 mesa-common-dev libqt4-opengl binutils-gold

edit flag offensive delete link more
0

answered 2012-09-10 05:06:59 -0500

SHPOWER gravatar image

Those libs was installed before the installation of rgbdslam

edit flag offensive delete link more

Comments

see above edited answer

Sudhan gravatar image Sudhan  ( 2012-09-10 22:08:00 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2012-09-09 07:17:08 -0500

Seen: 392 times

Last updated: Sep 10 '12