Ask Your Question
1

[ INFO] [1345647384.436612487]: Still waiting on map...

asked 2012-08-22 04:57:33 -0500

buma676 gravatar image

updated 2012-08-22 05:19:18 -0500

rosrun rviz rviz -d rospack find turtlebot_navigation/nav_rviz.vcg

When I ran this on my turtlebot, as directed here, the turtlebot kept repeating "Still waiting on map...". I then continued, and started rviz, with the command given on the webpage. When it started, the rviz screen was black, and no map was being shown. I tried teleoping it around the room to see if I could pick something up, but it still remained black. Any ideas on what the problem might be, or how to make a map using my turtlebot? Thanks!


Also, when i try to run

roslaunch turtlebot_calibration calibrate.launch

it says "Still waiting for scan"

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
0

answered 2012-09-16 18:06:33 -0500

hello,

I C the Q is approx a month old, hope u have figured it out.

I was following the same tutorial, but for simulation (later I saw http://www.ros.org/wiki/turtlebot_simulator/Tutorials/Building%20a%20Map%20in%20TurtleBot%20Simulator),

But everything was exactly same except one parameter missing in tutlebot_gazebo/launch/robot.launch

I only needed to add :

<param name="output_frame" value="odom"/>

in the odometry estimator i.e., in the tag:-

 <node pkg="robot_pose_ekf" type="robot_pose_ekf" name="robot_pose_ekf">

so now this node, in robot.launch looks like:-



  <!-- The odometry estimator -->

  <node pkg="robot_pose_ekf" type="robot_pose_ekf" name="robot_pose_ekf">
    <param name="freq" value="30.0"/>
    <param name="sensor_timeout" value="1.0"/>
    <param name="publish_tf" value="true"/>
    <param name="odom_used" value="true"/>
    <param name="imu_used" value="false"/>
    <param name="vo_used" value="false"/>
    <param name="output_frame" value="odom"/>     <!-- This is not present in tutrtlebot_gazebo's robot.launch -->
  </node>

 

Only with this modification I am now able to make the map correctly.

Hope it helps.

edit flag offensive delete link more
0

answered 2012-09-23 08:32:58 -0500

SHPOWER gravatar image

Change a view option on the right side of the screen it should solve the problem.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2012-08-22 04:57:33 -0500

Seen: 483 times

Last updated: Sep 23 '12