Unable to install ROS-humble packages

asked 2023-07-26 20:36:23 -0500

Shivi gravatar image

Hello, I downloaded the Ubuntu server 22.04 on raspberry pi for my turtlebot3. I want to use ROS humble which requires 22.04. However, I am not able to install any of the ros packages on it and I am getting an error of "Unable to locate package". I looked up the Ubuntu website and got to see that the jammy (22.04) ubuntu has no ros-humble packages.

Can anyone help me with what I should do?

edit retag flag offensive close merge delete


What happens, if you just try to install any other package on your Ubuntu system or upgrade it? E.g.

$sudo apt update
$sudo apt upgrade
Andromeda gravatar image Andromeda  ( 2023-07-27 05:47:14 -0500 )edit

I tried doing that and it did upgrade all the existing packages, however, I am still not able to install ros. I am using this command

sudo apt install ros-humble-desktop
Shivi gravatar image Shivi  ( 2023-07-27 08:10:01 -0500 )edit

Maybe you missed this step?

Andromeda gravatar image Andromeda  ( 2023-07-28 08:53:47 -0500 )edit