ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | Q&A
Ask Your Question

When I run the roslaunch command, an RLException error occurs

asked 2023-01-26 01:19:08 -0500

jun-gil gravatar image

updated 2023-01-26 02:57:51 -0500

gvdhoorn gravatar image

The text is the same as the title. I tried various methods on google to solve this error. But it doesn't work, so I need your help. Anyone is welcome, please help me to solve this error.

awesometech@awesometech:~/catkin_ws$ roslaunch urs_wearable world.launch

... logging to /home/awesometech/.ros/log/165b93fc-9d30-11ed-967c-a99cf3fa13f4/roslaunch-awesometech-4851.log Checking log directory for disk usage. This may take a while. Press Ctrl-C to interrupt Done checking log file disk usage. Usage is <1GB.
RLException: while processing /home/awesometech/catkin_ws/src/URSSimEnvironments/urs_wearable/launch/world.launch: while processing /home/awesometech/catkin_ws/src/URSSimEnvironments/urs_wearable/launch/world.launch: .. Invalid tag: maximum recursion depth exceeded while calling a Python object.
Arg xml is The traceback for the exception was written to the log file

this is my code I think there is no error in this code.

<?xml version="1.0"?>
  <include file="$(find urs_wearable)/launch/world.launch">
    <arg name="world" value="$(find urs_wearable)/worlds/" />
    <arg name="reference_latitude" value="32.319939" />
    <arg name="reference_longitude" value="-106.763657" />

The path was specified correctly. I don't know how many days I've been struggling with this problem. please anyone give me a solution

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted

answered 2023-01-26 03:01:24 -0500

gvdhoorn gravatar image

You appear to be roslaunch-ing a file called world.launch, which is hosted by a package called urs_wearable.

That file includes a file called world.launch, which is also located in the package urs_wearable (ie: the same package).

From the traceback, it's clear this leads to the situation where roslaunch is trying to load the file world.launch, which tries to include the file world.launch, which tries to include the file world.launch, which tries to include the file world.launch, which tries to include the file world.launch, which tries to include the file world.launch, etc, ad infinitum -- or in this case, until the Python interpreter reaches an internal limit and "just gives up".

Summarising: you need to prevent the infinite recursion.

Could you clarify why you include the same file you are already trying to roslaunch? If you avoid that, I believe you'd avoid the problem you encounter.

edit flag offensive delete link more


As you said, I removed the <include> part and the error went away! But Gazebo doesn't run. What should I do?

jun-gil gravatar image jun-gil  ( 2023-01-26 23:31:57 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools


Asked: 2023-01-26 01:19:08 -0500

Seen: 27 times

Last updated: Jan 26