Ask Your Question
0

Problem with roslaunch on a local machine

asked 2014-09-17 07:39:28 -0600

zeinab gravatar image

Hi, I have a robot which is my ros_master and my local machine which is able to to list the nodes and topics and also do rosrun. I have ROS_MASTER_URI, ROS_HOSTNAME and ROS_IP correctly set on both machines. However when I want to start a package on my local machine using roslaunch ( in my case I am trying to launch gmapping) I have problems. My local machine tries to run roscore locally and it gives me errors.

Thanks in advance for helping me out.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2014-09-18 07:09:50 -0600

zeinab gravatar image

updated 2014-09-18 07:10:20 -0600

Apparently I had set the ROS_HOSTNAME to the name of my ros_master instead of the name of my local machine. So for this to work we need to set the ROS_HOSTNAME to the name of the local machine ( in /etc/hosts) or its IP, set the ROS_IP to the ip of the local machine and ROS_MASTER_URI to the ip of the master.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2014-09-17 07:39:28 -0600

Seen: 112 times

Last updated: Sep 18 '14