Ask Your Question
1

Turtlebot Bringup

asked 2012-08-10 06:32:00 -0500

buma676 gravatar image

updated 2012-08-13 08:59:02 -0500

So I am going back through the steps of the bringup, since the demos are not working, and I try

hyness@turtlebot:~$ roslaunch turtlebot_bringup minimal.launch
... logging to /home/hyness/.ros/log/e48df4ec-e303-11e1-b4b3-94dbc99cb3ba/roslaunch-turtlebot-17513.log
Checking log directory for disk usage. This may take awhile.
Press Ctrl-C to interrupt
Done checking log file disk usage. Usage is <1GB.

Unable to contact my own server at [http://192.168.1.100:56965/].
This usually means that the network is not configured properly.

A common cause is that the machine cannot ping itself.  Please check
for errors by running:

    ping 192.168.1.100

For more tips, please see

    http://www.ros.org/wiki/ROS/NetworkSetup

hyness@turtlebot:~$

It works fine when I ping that IP; what is the problem here? how do I fix it? Thanks!


hyness@turtlebot:~$ env | grep ROS
ROS_ROOT=/opt/ros/fuerte/share/ros
ROS_PACKAGE_PATH=/opt/ros/fuerte/share:/opt/ros/fuerte/stacks
ROSLISP_PACKAGE_DIRECTORY=/opt/ros/fuerte/share/common-lisp/ros
ROS_MASTER_URI=http://192.168.1.101:11311
ROS_DISTRO=fuerte
ROS_IP=192.168.1.101
ROS_ETC_DIR=/opt/ros/fuerte/etc/ros
edit retag flag offensive close merge delete

Comments

thanks, but every time I run it it shows different ports, and I already have the ROS_MASTER_URI set with :11311, so thats not the problem

buma676 gravatar image buma676  ( 2012-08-10 06:49:48 -0500 )edit

Originally I was using ROS_HOSTNAME, and it wasnt working, so now I am using ROS_IP instead; the error above was using ROS_IP. I have gone through the network settings, and am able to get all of the tests at the bottom working; not sure what is going wrong.

buma676 gravatar image buma676  ( 2012-08-10 08:56:06 -0500 )edit

one command I usually run before doing any launch is "env | grep ROS" It lets me see all the ROS settings at a glance to confirm I've got them all correct, because you never know if you've done some export previously that you have forgotten about.

weiin gravatar image weiin  ( 2012-08-12 15:58:19 -0500 )edit

so from your environment variables, you can see your master uri and ip do not match your computer's ip (if it is indeed 192.168.1.100). it would be good to double check with "ifconfig". Answers by Lorenz and Rydel should work

weiin gravatar image weiin  ( 2012-08-13 14:55:32 -0500 )edit

3 Answers

Sort by ยป oldest newest most voted
2

answered 2012-08-13 12:54:20 -0500

rlinsalata gravatar image

If you use ROS_HOSTNAME it will override ROS_IP. However, if you set it to ROS_HOSTNAME=localhost, it will also attach itself to the local-only loopback interface - in other words, you can set it to localhost to cut off any remote access, but it should be a good test to make sure you can launch the nodes, bring-up the turtlebot and that (parts of) ROS are installed correctly. (oh, but you can still ssh into your turtlebot to run stuff remotely)

I'm not the most knowledgeable about networks, but I have been banging my head against them for the past few weeks myself, so I see two other things:

  1. Your IP address appears to be behind a private wifi router (maybe, yes?). If you have control of the router, try giving your turtlebot a static IP. This could help a lot.

  2. I assume that you eventually may want to access your turtlebot from ROS on other computers, what types of OS are you using on those other computers (Linux, Windows, Mac)? And more importantly, what are your results from pinging the hostname 'turtlebot' and the other "Checks" listed on the Network page Lorenz listed? (1.1, and 1.2)

edit flag offensive delete link more
2

answered 2012-08-10 06:41:30 -0500

Rydel gravatar image

the default port is 11311, I don't have any experience with changing the port so I'm not certain that is the problem but try changing your .bashrc file:

export ROS_MASTER_URI=http://192.168.1.100:11311

export ROS_HOSTNAME=192.168.1.100

edit flag offensive delete link more
1

answered 2012-08-10 07:06:23 -0500

Lorenz gravatar image

Try setting ROS_IP:

export ROS_IP=192.168.1.100

and try the network setup steps here if this doesn't help.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2012-08-10 06:32:00 -0500

Seen: 1,973 times

Last updated: Aug 13 '12