Ask Your Question
3

Latest RVIZ Fails to start using ROS Fuerte and Ubuntu 10.4 [closed]

asked 2012-08-08 05:32:02 -0500

Arrakis gravatar image

updated 2012-08-16 02:12:26 -0500

I have had no rviz problems since the launch of Fuerte with my current setup ROS Fuerte installed through the recommended repositories in ROS documentation, on Ubuntu 10.4

This morning after (presumably) a repository update, rviz no longer starts. I get the following error message when I try to load it

X Error: BadRequest (invalid request code or no such operation) 1 Extension: 135 (Uknown extension) Minor opcode: 187 (Unknown request) Resource id: 0x6a00003 rviz: ../../src/xcb_io.c:549: _XRead: Assertion `dpy->xcb->reply_data != ((void *)0)' failed. Aborted

The same error is produced when I try to load image_view under the rviz package too.

Any suggestions? I have removed the .rviz folder with no luck.

Thanks in advance


Update: For some reason I can't add an answer for this post so here is the "solution" to my problem.

Update RVIZ to the latest version, as of a week after I originally asked the question.

I originally had in my post that I suspected the source of my problem was a broken code commit. This hypothesis was removed by a moderator. Given the solution to the problem, it is almost certain that my hypothesis was correct. In the interests of providing others with information to help their problems, I would ask that this solution and explanation is not removed.

Many thanks

edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by tfoote
close date 2012-10-08 08:30:25

1 Answer

Sort by ยป oldest newest most voted
0

answered 2012-08-10 02:28:13 -0500

Charence gravatar image

updated 2012-08-10 06:51:49 -0500

I have encountered the same problem!!

I believe an update to my ROS installation is the cause of the problem on Ubuntu 10.04 as you suspected. I have tried to reinstall ROS.

Since nobody else has raised this issue yet, I suppose it is just a problem with 10.04? If so, upgrading to a later release may help. However, I'm not able to upgrade my work PC to 11.10 or 12.04 yet.

edit flag offensive delete link more

Comments

2

Hi Charence. Since this isn't an answer to the question it doesn't belong in this section. Please delete this answer, and use the comment section if you'd like to comment.

Asomerville gravatar image Asomerville  ( 2012-08-10 05:10:08 -0500 )edit
1

Sorry, I cannot see how your comment is helpful to the opening poster's question, to me or anybody else who recently came across this problem. I got this problem after doing an update. It appears that rviz in Fuerte just doesn't work in 10.04 and I believe it is beneficial to make others aware of it

Charence gravatar image Charence  ( 2012-08-10 06:37:41 -0500 )edit
3

I don't mean to attack you. I'm attempting to clarify the way to use the ros answers system. It appears that you accidentally posted a comment in the answers section instead of the comments section. The original contents of your post were: "I have encountered the same problem!" without suggestion.

Asomerville gravatar image Asomerville  ( 2012-08-10 07:15:25 -0500 )edit

Question Tools

1 follower

Stats

Asked: 2012-08-08 05:32:02 -0500

Seen: 357 times

Last updated: Aug 16 '12