Ask Your Question
1

ros install on debian sid

asked 2012-08-04 06:36:43 -0500

Fabien R gravatar image

updated 2014-01-28 17:13:14 -0500

ngrennan gravatar image

Hello,

I installed fuerte catkin on my amd64/sid. rosdep check ros_comm ran OK. But rosdep install turtlesim returned

ERROR: the following packages/stacks could not have their rosdep keys resolved to system dependencies: turtlesim: No definition of [qt4-qmake] for OS [debian]

Thus I updated my file rosdep.yaml by adding these lines:

qt4-qmake: debian: qt4-qmake

I updated the file /etc/ros/rosdep/sources.list.d/20-default.list by adding this line:

yaml file:///home/fabien/robot/ros/ros/rosdep.yaml debian

But rosdep update ends with this error:

ERROR: invalid sources list file: line: yaml file:///home/fabien/robot/ros/ros/rosdep.yaml debian url must be a fully-specified URL with scheme, hostname, and path: file:///home/fabien/robot/ros/ros/rosdep.yaml

Any hints

edit retag flag offensive close merge delete

Comments

@joq: Ok. I will give a try to commit my changes. As I'm not yet familiar with git, I hope I will not mess things up :-)

Fabien R gravatar image Fabien R  ( 2012-08-11 05:26:55 -0500 )edit

I encountered this problem while I tested the update from my git repository: ERROR: unable to process source [https://github.com/theedge123/rosdistro/blob/master/rosdep/debian.yaml]: mapping values are not allowed here in "<string>", line 6, column 19:

Fabien R gravatar image Fabien R  ( 2012-08-11 06:48:56 -0500 )edit

3 Answers

Sort by ยป oldest newest most voted
1

answered 2012-08-05 04:44:12 -0500

joq gravatar image

The best solution is to contribute the missing rules.

That way, the problem you discovered will be fixed for other Debian users.

edit flag offensive delete link more
1

answered 2014-06-12 10:44:29 -0500

Jose Luis gravatar image

I had the same problem as you have. In my case, I've gotten it to work with the same sentence without "debian" at the end.

That is to say: yaml file:///home/fabien/robot/ros/ros/rosdep.yaml

Obviously with my package path.

I hope it helps you

edit flag offensive delete link more
0

answered 2012-08-05 04:22:09 -0500

Fabien R gravatar image

I had to put the file rosdep.yaml on a local webserver to make it work.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2012-08-04 06:36:43 -0500

Seen: 436 times

Last updated: Jun 12 '14