ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question
1

Theora_image_transport Packet not paired through ROS1_Bridge

asked 2022-06-08 10:12:56 -0500

Mechaick gravatar image

updated 2022-07-02 07:56:06 -0500

lucasw gravatar image

Hello,

Laptop on Ubuntu 20.4 Noetic and Foxy installed.

I'm running a usb_cam node on my laptop on Noetic.

When I run ROS1_bridge, the image_raw and image_raw/compressed are forwarded to ROS2 but not the image_raw_theora topic.

I checked if the pair was available with ROS1_bridge and it's not the case. As far as I understood, when compiling ros1_bridge is looking for every *_msgs package. The issue here is that theora_image_transport is not finishing by msgs

I tried to compile on my own the package image transport but It didn't changed anything.

Do you have any clues on the issue ?

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2022-06-10 06:24:17 -0500

Mechaick gravatar image

I solved the issue by forking the ros1_bridge. The issue was that ros1_bridge only forward messages that are from a package finishing by "_msgs"

If needed here is my fork, you can also easily implement any package not finishing by _msgs just by modifying the lines 481 and 482 of __init.py https://github.com/Mechaick/ros1_bridge

edit flag offensive delete link more

Question Tools

4 followers

Stats

Asked: 2022-06-08 10:12:56 -0500

Seen: 191 times

Last updated: Jun 10 '22