ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | Q&A answers.ros.org
Ask Your Question
0

ignition gazebo with foxy ros2

asked 2022-05-31 11:13:10 -0500

r_gerson gravatar image

I am following this tutorial https://docs.ros.org/en/foxy/Tutorial... when i run the following command: ign gazebo -v 4 -r visualize_lidar.sdf

i get the following output:

The 'ign' command provides a command line interface to the ignition tools.

ign <command> [options]

List of available commands:

help: Print this help text. sdf: Utilities for SDF files. topic: Print information about topics. service: Print information about services. log: Record or playback topics. msg: Print information about messages. plugin: Print information about plugins. fuel: Manage simulation resources.

Options:

--force-version <version> Use a specific library version. --versions Show the available versions. --commands Show the available commands. Use 'ign help <command>' to print help for a command.

why is this happening? how can i run the example?

i installed gazebo using this tutorial. https://classic.gazebosim.org/tutoria... i am running foxy on ubuntu 20.04 (via VMware on a mac)

edit retag flag offensive close merge delete

Comments

https://classic.gazebosim.org/tutoria... installs "gazebo classic", which can be launched with gazebo visualize_lidar.sdf.

If you want to use "ignition gazebo" you'll need to follow a different route and install Ignition Gazebo Citadel, see the version matrix & instructions here: https://github.com/gazebosim/ros_gz/t...

clyde gravatar image clyde  ( 2022-05-31 13:55:03 -0500 )edit

that command doesn't seem to work. when i execute that command, i get:

context mismatch in svga_surface_destroy context mismatch in svga_surface_destroy

r_gerson gravatar image r_gerson  ( 2022-05-31 14:33:09 -0500 )edit

also, i never actually downloaded the file visualize_lidar.sdf. does that matter?

r_gerson gravatar image r_gerson  ( 2022-05-31 14:34:27 -0500 )edit

That's a different problem -- I think it has to do with VMWare & Gazebo, and I'm afraid that I can't help there. You might try posting that here: https://answers.gazebosim.org/questions/

clyde gravatar image clyde  ( 2022-05-31 14:36:05 -0500 )edit

oh got it, thank you Clyde!

r_gerson gravatar image r_gerson  ( 2022-05-31 14:39:56 -0500 )edit

so, i installed ignition gazeo, and upon running ign gazebo -v 4 -r visualize_lidar.sdf

i get the following output: [Wrn] [ign.cc:86] Fuel world download failed because Fetch failed. Other errors Unable to find or download file

r_gerson gravatar image r_gerson  ( 2022-05-31 14:50:44 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
1

answered 2022-06-01 01:49:12 -0500

Joe28965 gravatar image

If you do want to use Ignition Gazebo and not Gazebo 11 I suggest looking at the tutorials for Gazebo Citadel, that's the version that's recommended for ROS2 Foxy. It also includes a link of requirements where it tells you how to install Citadel.

I'm not sure if the tutorial you've linked is up to date. It might very well be. However, the tutorial I linked is from the folks over at Gazebo.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2022-05-31 11:13:10 -0500

Seen: 264 times

Last updated: Jun 01