Ask Your Question
0

initializing roscore, unkown host

asked 2012-07-30 03:02:49 -0500

Flowers gravatar image

Hey,

OS: Fedora 14 ROS: Fuerte

Error, while initializing roscore:

Unable to contact my own server at [http://scitos:50689/]. This usually means that the network is not configured properly.

A common cause is that the machine cannot ping itself. Please check for errors by running:

ping scitos

For more tips, please see

http://www.ros.org/wiki/ROS/NetworkSetup

ping scitos delivers

unkown host scitos

ping localhost works fine, ping 127.0.0.1 likewise

Solutions according to ros-wiki is to set

ROS_HOSTNAME=localhost ROS_MASTER_URI=http://localhost:11311

this has not worked ping $ROS_HOSTNAME does fine, while ping $ROS_MASTER_URI returns

unknown host http://localhost:11311

Any ideas why this does not work? Maybe some issue concerning my network connection(using wireless for internet, still there are two ethernet accesses, which are currently not used)?

thx :-)

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
0

answered 2012-07-30 03:11:52 -0500

dornhege gravatar image

updated 2012-07-30 03:13:30 -0500

It's clear that you can't ping the ROS_MASTER_URI. Pinging the host in the ROS_MASTER_URI is the correct way.

Could you run a roscore after setting ROS_HOSTNAME?

The other way is checking your /etc/hosts. There should probably be a line like:

127.0.0.1   localhost

If you add

127.0.0.1   scitos

after that, you should be able to do ping scitos.

edit flag offensive delete link more
0

answered 2012-07-30 03:19:08 -0500

Flowers gravatar image

updated 2012-07-30 03:20:50 -0500

Nope, it did not work, but I've found my mistake.

It seems that setting the value in .bashrc is not enough, you've got to write "export ROS_HOSTNAME=localhost" and then launching the roscore is no problem.

edit:

Thx a lot, that was the next thing I thought of.

edit flag offensive delete link more

Comments

Putting the export... line in .bashrc should be sufficient. You'll need to source .bashrc, though. Once you open new terminals that should already be loaded. You can check with echo $ROS_HOSTNAME.

dornhege gravatar imagedornhege ( 2012-07-30 03:39:36 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2012-07-30 03:02:49 -0500

Seen: 2,084 times

Last updated: Jul 30 '12