ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

Problems installing ROS1 Packages

asked 2022-05-13 16:47:01 -0600

isiko gravatar image

I'm normaly working with ROS2, so probably my Problems originate from not having that much experience with ROS in general and especially not with ROS1, but I have a package that's only provided in ROS1 but that I need for generating some worlds. Hover, I really struggle to install it.

What I tried

First thing I tried was just running

rosdep install virtual_maize_field

which resulted in the following error:

ERROR: Rosdep cannot find all required
resources to answer your query
Missing resource virtual_maize_field
ROS path [0]=/opt/ros/melodic/share/ros
ROS path [1]=/opt/ros/melodic/share

Next, I tried cloning the Repository and then trying to install it with rosdep via the path:

git clone
rosdep install --from-path virtual_maize_field

This resulted in a lot of packages being installed, but when I tried to run a script, I just got the response that the package could not be found.

[rospack] Error: package 'virtual_maize_field' not found

After that, I tried following this article, but that got me the same result as before; the package couldn't be found :/

Thanks in advance :)

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted

answered 2022-05-13 18:24:18 -0600

ljaniec gravatar image

Your linked repository seems to have a ros2branch there:

Did you try it?

The code seems to be mostly non-ROS specific to be honest, it can be ported to ROS2.

Did you build it with catkin make? rosdep is for dependency packages

edit flag offensive delete link more



Thanks, didn't even realize that :D

isiko gravatar image isiko  ( 2022-05-14 04:24:03 -0600 )edit

Question Tools



Asked: 2022-05-13 16:47:01 -0600

Seen: 99 times

Last updated: May 13 '22