Ask Your Question
0

Robot doesn't follow plan close enough

asked 2012-07-26 23:14:34 -0500

Febo gravatar image

Hello,

I've created my own global path planner (local planner is default one), that uses some additional information to create path, so the path may seem longer than it should be but it is not. The problem is that turtlebot doesn't follow it close enough, it "cuts" corners around 0.5m-1m before it should. I've changed path_distance_bias to 0.1 but it doesn't seem to help. Here is my launch file.

<launch>
  <!-- start gazebo with an empty plane -->
  <param name="/use_sim_time" value="true" />

  <node name="gazebo" pkg="gazebo" type="gazebo" args="-u $(find rins_simulation)/worlds/world3.world" respawn="false" output="screen"/>

  <include file="$(find rins_simulation)/launch/turtlebot_kinect.launch">
     <arg name="robot_pose" value="-x 3.5 -y 1" />
  </include>

  <!--- Run gmapping -->
  <include file="$(find rins_navigation)/config/gmapping_turtlebot.launch" />


    <!--- Run Move Base -->
  <node pkg="move_base" type="move_base" respawn="false" name="move_base" output="screen">
        <include file="$(find turtlebot_navigation)/config/move_base_turtlebot.launch" />
    <param name="base_global_planner" value="my_navigator/MyNavigator"/>


        <rosparam file="$(find turtlebot_navigation)/config/costmap_common_params.yaml" command="load" ns="global_costmap" />
    <rosparam file="$(find turtlebot_navigation)/config/costmap_common_params.yaml" command="load" ns="local_costmap" />
    <rosparam file="$(find turtlebot_navigation)/config/local_costmap_params.yaml" command="load" />
    <rosparam file="$(find turtlebot_navigation)/config/global_costmap_params.yaml" command="load" />
    <rosparam file="$(find turtlebot_navigation)/config/base_local_planner_params.yaml" command="load" />

        <param name="TrajectoryPlannerROS/path_distance_bias" value="0.10" />
  </node>

</launch>

Here is a picture of robot not following path. (blue line is global path, red line is local). Distance between two horizontal lines is 0.5m image description image description

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2012-07-26 23:40:26 -0500

KruseT gravatar image

The local planning approach in the navigation stack only works well for global paths which have no unnecessary U-shapes.

You could try to increase the value of path_distance_bias to some value like 5.0. However you will always have problems if you try to make your robot follow non-sparse path using one of the local planners of the navigation stack.

If you need to do it, you probably have to modify the local planner so that the goal_distance_bias chooses a different point as local goal than what it currently chooses.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2012-07-26 23:14:34 -0500

Seen: 1,275 times

Last updated: Jul 26 '12