Ask Your Question
0

rviz rendering issues (disjointed triangles)

asked 2012-07-26 15:43:18 -0500

updated 2014-01-28 17:13:09 -0500

ngrennan gravatar image

I'm running ROS fuerte in Ubuntu 12.04LTS. Complete fresh installation. No issues setting it up.

The problem appears whenever I try to render a model in rviz I get only a partially rendered model. For example if I launch the Motoman planning components with the line;

roslaunch sia10d_mesh_arm_navigation planning_components_visualizer.launch

I get a render of a a bunch of disjointed triangles which almost represent the robot.

I figure this may be an issue with my graphics card, which is a NVidia Geforce GT630M with Optimus (Which I know linux doesn't support the Optimus technology). I believe Ubuntu ignores the Nvidia card in this setup (by default) and just uses the Intel integrated graphics.

Everything else seems to run fine. Other 3D graphics packages display .stl files fine, it just seems to be an issue with rviz and this setup.

I was wondering if anyone else has come across this issue, and whether there is an easy fix, or should I do battle with trying to upgrade my graphic driver?

Update: Can render .dae (Collada) files. Possibly similar to this: https://code.ros.org/trac/ros-pkg/ticket/5111

edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
1

answered 2012-10-15 14:43:04 -0500

updated 2012-10-15 14:44:12 -0500

The problem is that Ubuntu 12.04 still does not support laptops with Optimus technology so they default to the Intel integrated graphics.

The Intel integrated graphics card on the Ivy-bridge i7's aren't well supported in linux yet either so they lack the ability to render certain 3D graphics.

There are a couple of solutions;

  • Get an older laptop that has a supported graphics card.
  • Attempt to trick the linux kernel into using the NVidia Card instead of the integrated graphics.
  • Just stick to using .dae files and dodge the graphics issues the best you can.
edit flag offensive delete link more

Comments

Can you disable the Optimus and force full-time use of the nvidia card via a BIOS setting? I know there are Dells and Thinkpads that have such an option.

Eric Perko gravatar imageEric Perko ( 2012-10-15 17:23:50 -0500 )edit
1

I have been using bumblebee (https://wiki.ubuntu.com/Bumblebee) on an optimus laptop with some success. Rviz and gazebo have been working quite well.

JonW gravatar imageJonW ( 2012-10-15 21:50:16 -0500 )edit

Correct answer. The problems you describe typically appear with most Intel GMA chip sets.

Martin Günther gravatar imageMartin Günther ( 2012-10-15 22:10:51 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2012-07-26 15:43:18 -0500

Seen: 625 times

Last updated: Oct 15 '12