Ask Your Question
1

rosmake: error: no such option: --rosdep-install

asked 2012-07-23 11:03:58 -0600

updated 2012-07-23 12:28:37 -0600

joq gravatar image

Hi, I found there's something wrong with the installation of openni_kinect as I followed this website:http://www.ros.org/wiki/openni_kinect.

But when I typed rosmake openni_kinect --rosdep-install in the terminal of Ubuntu12.04, it displays rosmake: error: no such option: --rosdep-install. I have already checked on the internet, the answer seems to be http://answers.ros.org/question/38291/no-such-option-rosdep-install/.

I have tried but it still doesn't work!!!Looking for help!!!! Thank you so much!

Lili

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
3

answered 2012-07-23 12:22:03 -0600

it seems that I should call rosdep install and rosmake seperately in fuerte: After I type rosdep install openni_kinect rosmake openni_kinect

rather than rosmake openni_kinect --rosdep-install in the terminal.

It finally works!!!

edit flag offensive delete link more

Comments

2

This is correct. The rosmake --rosdep-install option is no longer available in Fuerte. Use an explicit rosdep install command, instead.

joq gravatar imagejoq ( 2012-07-23 12:27:53 -0600 )edit
1

answered 2012-07-23 11:12:13 -0600

allenh1 gravatar image

At the bottom of the install page for fuerte, you find these instructions:

sudo apt-get install python-setuptools python-pip

sudo easy_install -U rosinstall vcstools rosdep

After you run this, you will have rosdep. If you are on Ubuntu, you should be able to install openni_kinect with your package manager.

sudo apt-get install ros-fuerte-openni-kinect
edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2012-07-23 11:03:58 -0600

Seen: 4,334 times

Last updated: Jul 23 '12