ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | Q&A
Ask Your Question

ros2 foxy not working- Windows10

asked 2022-01-17 23:11:15 -0500

Sid7117 gravatar image

updated 2022-01-20 05:49:26 -0500

Hi all, I have installed ros2 foxy on my windows 10 machine. I was able to run example nodes in the tutorial initially but now its indefinitely waiting after the run command is issued.

I followed the instructions mentioned here to install ros2.

I tried removing ros2 using "rmdir /s /q C:\opt\" command and reinstalling according to the above mentioned steps but it didn't help. I also checked reinstalling Visual studio 2019.

How can i bring the ros module to working condition? Any help in this regard is greatly appreciated.

edit retag flag offensive close merge delete


Hi @Sid7117 what instructions did you use for installation? This may help me understand what to recommend to remove ROS2

osilva gravatar image osilva  ( 2022-01-18 13:45:35 -0500 )edit

Hi @osilva, I followed the instructions mentioned here to install ros2.

Sid7117 gravatar image Sid7117  ( 2022-01-18 22:55:42 -0500 )edit

In that case this should do it:

rmdir /s /q c:\opt

osilva gravatar image osilva  ( 2022-01-19 01:06:23 -0500 )edit

I tried this. Still the issue is there after reinstall. I could source the ros module and build a package using colcon build. But it wont execute a node if i try to run. It just waits indefinitely.

Sid7117 gravatar image Sid7117  ( 2022-01-19 01:36:43 -0500 )edit

Have you tried reinstalling VS2019 as well?

osilva gravatar image osilva  ( 2022-01-19 04:14:24 -0500 )edit

Also make sure to do:

set ChocolateyInstall=c:\opt\chocolatey
choco upgrade all -y --execution-timeout=0
osilva gravatar image osilva  ( 2022-01-19 04:16:00 -0500 )edit

Yes, I tried reinstalling VS2019

Sid7117 gravatar image Sid7117  ( 2022-01-20 01:44:08 -0500 )edit

Please document what you have already tried and edit your question. Otherwise you are having answerers guessing and it’s unproductive

osilva gravatar image osilva  ( 2022-01-20 04:23:32 -0500 )edit

1 Answer

Sort by » oldest newest most voted

answered 2022-01-24 09:55:21 -0500

rdhotre gravatar image

updated 2022-01-25 03:26:43 -0500

Uninstalled everything mentioned in this previous installation of ROS2

OpenCV, OpenSSL,DDS,Edited the Path variable to remove there added paths.

Installed ROS2 on windows using below guide

Then ros2 node started working. Finally.

edit flag offensive delete link more


Hi @rdhotre the link is not working. Can you check pls

osilva gravatar image osilva  ( 2022-01-24 11:05:57 -0500 )edit

Thank you for fixing link

osilva gravatar image osilva  ( 2022-01-25 04:24:41 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools



Asked: 2022-01-17 23:11:15 -0500

Seen: 117 times

Last updated: Jan 25 '22