[Ubuntu 20.04, ROS2 galactic] Cannot open RQT, error given: 'ValueError: PyCapsule_GetPointer called with incorrect name'

asked 2021-12-23 07:56:42 -0500

evanvandro gravatar image

Hello everyone! Apparently it's a common problem but I could not find a solution that worked with my installation.

I'm using Ubuntu Focal Fossa, tried both ROS2 Foxy and Galactic but I can't get to rqt work.

I installed everything by apt and removed both PyQt5 and PyQt5-sip from pip3 as explained in some answers, but this still doesn't work for me.

Does anyone have any idea of what might be the problem?

Traceback (most recent call last): File "/opt/ros/galactic/bin/rqt", line 11, in <module> load_entry_point('rqt-gui==1.1.2', 'console_scripts', 'rqt')() File "/opt/ros/galactic/lib/python3.8/site-packages/rqt_gui/main.py", line 87, in main sys.exit(Main().main()) File "/opt/ros/galactic/lib/python3.8/site-packages/rqt_gui/main.py", line 57, in main return super( File "/opt/ros/galactic/lib/python3.8/site-packages/qt_gui/main.py", line 408, in main from python_qt_binding import QT_BINDING File "/opt/ros/galactic/lib/python3.8/site-packages/python_qt_binding/__init__.py", line 56, in <module> from python_qt_binding.binding_helper import loadUi # noqa: F401 File "/opt/ros/galactic/lib/python3.8/site-packages/python_qt_binding/binding_helper.py", line 277, in <module> _select_qt_binding( File "/opt/ros/galactic/lib/python3.8/site-packages/python_qt_binding/binding_helper.py", line 108, in _select_qt_binding QT_BINDING_VERSION = binding_loader(required_modules, optional_modules) File "/opt/ros/galactic/lib/python3.8/site-packages/python_qt_binding/binding_helper.py", line 155, in _load_pyqt _named_optional_import('PyQt5.%s' % module_name) File "/opt/ros/galactic/lib/python3.8/site-packages/python_qt_binding/binding_helper.py", line 142, in _named_optional_import _named_import(name)

File "/opt/ros/galactic/lib/python3.8/site-packages/python_qt_binding/binding_helper.py", line 133, in _named_import module = builtins.__import__(name) ValueError: PyCapsule_GetPointer called with incorrect name

edit retag flag offensive close merge delete