Ask Your Question
0

ERROR: rosrun rqt_tf_tree rqt_tf_tree

asked 2021-11-07 10:14:38 -0500

Kevin1719 gravatar image

I was trying to visualize the tf tree of a running system using:

$ rosrun rqt_tf_tree rqt_tf_tree

but this came up:

PluginHandlerDirect._restore_settings() plugin "rqt_tf_tree/RosTfTree#0" raised an exception:
Traceback (most recent call last):
  File "/opt/ros/noetic/lib/python3/dist-packages/qt_gui/plugin_handler_direct.py", line 121, in _restore_settings
    self._plugin.restore_settings(plugin_settings_plugin, instance_settings_plugin)
  File "/opt/ros/noetic/lib/python3/dist-packages/rqt_tf_tree/tf_tree.py", line 131, in restore_settings
    self._refresh_tf_graph()
  File "/opt/ros/noetic/lib/python3/dist-packages/rqt_tf_tree/tf_tree.py", line 143, in _refresh_tf_graph
    self._update_graph_view(self._generate_dotcode())
  File "/opt/ros/noetic/lib/python3/dist-packages/rqt_tf_tree/tf_tree.py", line 150, in _generate_dotcode
    return self.dotcode_generator.generate_dotcode(dotcode_factory=self.dotcode_factory,
  File "/opt/ros/noetic/lib/python3/dist-packages/rqt_tf_tree/dotcode_tf.py", line 96, in generate_dotcode
    data = yaml_parser.load(yaml_data)
TypeError: load() missing 1 required positional argument: 'Loader'

I'm using ROS Noetic in Ubuntu 20.04. I didn't meet this error in previous Ubuntu 18.04 version. Can anyone help me out with this?

edit retag flag offensive close merge delete

Comments

There is a prior answer but not with Noetic but pls check just to discard the possibility: https://answers.ros.org/question/2926...

osilva gravatar image osilva  ( 2021-11-07 12:00:06 -0500 )edit

Thanks a lot for your reply. I could still run the command normally last time, but when I reinstall my ubuntu 20.04 with Noetic, I met this error. I think it's because something was missing that I need to install?

Kevin1719 gravatar image Kevin1719  ( 2021-11-08 06:55:42 -0500 )edit

I believe you are right about missing something in the new install. It may be with dot

Try sudo dot -c

osilva gravatar image osilva  ( 2021-11-08 07:34:39 -0500 )edit

Not working. I have tried to reinstall ROS but nothing changed.

Kevin1719 gravatar image Kevin1719  ( 2021-11-09 10:19:52 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
1

answered 2021-11-09 10:37:08 -0500

Kevin1719 gravatar image

I have solved the problem by reinstall pyyaml:

$ sudo pip uninstall pyyaml
$ pip install pyyaml
edit flag offensive delete link more

Comments

This helped. Lovely, Thank you

sillymanTony gravatar image sillymanTony  ( 2022-02-01 04:42:21 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2021-11-07 10:14:38 -0500

Seen: 307 times

Last updated: Nov 09 '21