Ask Your Question
0

Control loop missed its desired rate of 20.0000Hz... the loop actually took 0.1200 seconds

asked 2021-10-07 09:45:55 -0500

harish556 gravatar image

when i start my navigation stack when i give 2d pose estimate i get this error

Ignoring initial pose in frame "odom"; initial poses must be in the global frame, "map"

then when i give 2d nav goal i get these errors

 WARN] [1633615470.911036041, 31.705000000]: Control loop missed its desired rate of 20.0000Hz... the loop actually took 0.1200 seconds

and the robot starts rotating a one place

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2021-10-08 08:04:59 -0500

divyam.rastogi gravatar image

The first warning occurs because probably your Fixed Frame is set to odom in Rviz. If you change it to the map frame, the warning should go away. If you do not have a map frame, then you can just publish a static transform from odom to map.

The second warning just tells you that you want the control loop to run at 20Hz i.e, 0.05 sec but actually it took 0.12 secs. You can just reduce your control frequency to 5 Hz or use a more powerful computer.

The in place rotation part can happen due to many reasons and you need to provide more information about how you set up your robot. It is most likely not related to the two warnings you mentioned.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2021-10-07 09:45:55 -0500

Seen: 81 times

Last updated: Oct 08 '21