Unable to Move Robot with Moveit rviz and gazebo

asked 2021-10-06 12:06:31 -0500

Captain_Cabinet gravatar image

updated 2022-03-03 09:43:14 -0500

lucasw gravatar image

I have successfully spawned in the robot into both gazebo and rviz using moveit on ros noetic and ubuntu 20, however whenever I try to move the robot using rviz the planning will succeed and the execution will either simply fail or say it has executed although the robot has not moved.

Additionally the robot will just slowly fall over time and slump as if nothing is telling it to hold its position. I created the urdf for gazebo and the launch files using the moveit setup assistant and there seem to be no obvious errors except for being unable to connect to a kinnect sensor ( i dont have one just haven't removed the code lines yet)

Attached are my urdf file, demo_gazebo.launch file and my ros.controllers launch and yaml file

I am unable to upload files as i require 5 points but i have copied and pasted the files below

demo_gazebo.launch

<launch>

  <!-- By default, we do not start a database (it can be large) -->
  <arg name="db" default="false" />
  <!-- Allow user to specify database location -->
  <arg name="db_path" default="$(find mycobot_moveit)/default_warehouse_mongo_db" />

  <!-- By default, we are not in debug mode -->
  <arg name="debug" default="false" />

  <!-- By default, we won't load or override the robot_description -->
  <arg name="load_robot_description" default="false"/>

  <!--
  By default, hide joint_state_publisher's GUI

  MoveIt's "demo" mode replaces the real robot driver with the joint_state_publisher.
  The latter one maintains and publishes the current joint configuration of the simulated robot.
  It also provides a GUI to move the simulated robot around "manually".
  This corresponds to moving around the real robot without the use of MoveIt.
  -->
  <arg name="use_gui" default="true" />

  <!-- Gazebo specific options -->
  <arg name="gazebo_gui" default="true"/>
  <arg name="paused" default="false"/>
  <!-- By default, use the urdf location provided from the package -->
  <arg name="urdf_path" default="$(find mycobot_moveit)/urdf/mycobot_moveit.urdf"/>

  <!-- launch the gazebo simulator and spawn the robot -->
  <include file="$(dirname)/gazebo.launch" >
    <arg name="paused" value="$(arg paused)"/>
    <arg name="gazebo_gui" value="$(arg gazebo_gui)"/>
    <arg name="urdf_path" value="$(arg urdf_path)"/>
  </include>

  <!-- If needed, broadcast static tf for robot root -->
    <node pkg="tf2_ros" type="static_transform_publisher" name="virtual_joint_broadcaster_0" args="0 0 0 0 0 0 world base" />


  <!-- We do not have a robot connected, so publish fake joint states -->
  <node name="joint_state_publisher" pkg="joint_state_publisher" type="joint_state_publisher">
    <param name="use_gui" value="$(arg use_gui)"/>
    <rosparam param="source_list">[move_group/fake_controller_joint_states]</rosparam>
    <rosparam param="source_list">[/joint_states]</rosparam>
  </node>
  <node name="joint_state_desired_publisher" pkg="topic_tools" type="relay" args="joint_states joint_states_desired" />

  <!-- Given the published joint states, publish tf for the robot links -->
  <node name="robot_state_publisher" pkg="robot_state_publisher" type="robot_state_publisher" respawn="true" output="screen" />

  <!-- Run the main MoveIt executable without trajectory execution (we do not have controllers configured by default) -->
  <include file="$(dirname ...
(more)
edit retag flag offensive close merge delete

Comments

1

@Captain_Cabinet FYI it is always preferred to add the text of relevant files to a question, exactly as you did, rather than uploading images. See section 5.2 of the Support guidelines. In the future, it is helpful to use the 101010 button to properly format code snippets. I've edited your question to take care of this formatting.

jarvisschultz gravatar image jarvisschultz  ( 2021-10-06 12:13:18 -0500 )edit