Building galactic with source code on windows fails

asked 2021-07-27 21:27:41 -0500

Rongcai gravatar image

updated 2021-07-29 12:34:45 -0500

Hello there,

I am following the instructions on http://docs.ros.org/en/galactic/index... to build galactic on windows but fails with below information. Could you help give some hits about how to resolve it and what's the reason?

Summary: 31 packages finished [31.9s] 1 package failed: iceoryx_posh 7 packages aborted: ament_cmake ament_cmake_gtest ament_cmake_pytest ament_index_python ros_environment test_interface_files test_osrf_testing_tools_cpp 291 packages not processed

Thanks Rongcai

edit retag flag offensive close merge delete

Comments

did you get any specific error message above in the colcon output? This output is just telling you that the package failed to build; it's almost impossible to help with that information only. This file should contain much more information: log\latest_build\iceoryx_posh\stdout_stderr.log

christophebedard gravatar image christophebedard  ( 2021-07-28 09:30:12 -0500 )edit

past the log content:log\latest_build\iceoryx_posh\stdout_stderr.log

-- Configuring done -- Generating done -- Build files have been written to: C:/dev/ros2_galactic/build/iceoryx_posh/dependencies/cpptoml/download 鐢ㄤ簬 .NET Framework 鐨?Microsoft (R) 鐢熸垚寮曟搸鐗堟湰 16.10.2+857e5a733 鐗堟潈鎵€鏈?C) Microsoft Corporation銆備繚鐣欐墍鏈夋潈鍒┿€?

Checking Build System Performing update step for 'ext_cpptoml' Building Custom Rule C:/dev/ros2_galactic/build/iceoryx_posh/dependencies/cpptoml/download/CMakeLists.txt No patch step for 'ext_cpptoml' No configure step for 'ext_cpptoml' No build step for 'ext_cpptoml' No install step for 'ext_cpptoml' No test step for 'ext_cpptoml' Completed 'ext_cpptoml' Building Custom Rule C:/dev/ros2_galactic/build/iceoryx_posh/dependencies/cpptoml/download/CMakeLists.txt -- Could NOT find Doxygen (missing: DOXYGEN_EXECUTABLE) -- Configuring done -- Generating done

Rongcai gravatar image Rongcai  ( 2021-07-29 10:03:08 -0500 )edit

-- Build files have been written to: C:/dev/ros2_galactic/build/iceoryx_posh/dependencies/cpptoml/build 鐢ㄤ簬 .NET Framework 鐨?Microsoft (R) 鐢熸垚寮曟搸鐗堟湰 16.10.2+857e5a733 鐗堟潈鎵€鏈?C) Microsoft Corporation銆備繚鐣欐墍鏈夋潈鍒┿€?

Checking Build System Building Custom Rule C:/dev/ros2_galactic/build/iceoryx_posh/dependencies/cpptoml/src/CMakeLists.txt -- Install configuration: "Debug" -- Up-to-date: C:/dev/ros2_galactic/build/iceoryx_posh/dependencies/install/include/cpptoml.h -- Up-to-date: C:/dev/ros2_galactic/build/iceoryx_posh/dependencies/install/lib/cmake/cpptoml/cpptomlTargets.cmake -- Up-to-date: C:/dev/ros2_galactic/build/iceoryx_posh/dependencies/install/lib/cmake/cpptoml/cpptomlConfigVersion.cmake -- Up-to-date: C:/dev/ros2_galactic/build/iceoryx_posh/dependencies/install/lib/cmake/cpptoml/cpptomlConfig.cmake -- [i] <<<<<<<<<<<<< Start iceoryx_posh configuration: >>>>>>>>>>>>> -- [i] Using m:n communication only! -- [i] IOX_MAX_PUBLISHERS:512 -- [i] IOX_MAX_SUBSCRIBERS:1024 -- [

Rongcai gravatar image Rongcai  ( 2021-07-29 10:03:52 -0500 )edit

-- [i] IOX_MAX_PUBLISHERS:512 -- [i] IOX_MAX_SUBSCRIBERS:1024 -- [i] IOX_MAX_INTERFACE_NUMBER:4 -- [i] IOX_MAX_SUBSCRIBERS_PER_PUBLISHER:256 -- [i] IOX_MAX_CHUNKS_ALLOCATED_PER_PUBLISHER_SIMULTANEOUSLY:8 -- [i] IOX_MAX_PUBLISHER_HISTORY:16 -- [i] IOX_MAX_CHUNKS_HELD_PER_SUBSCRIBER_SIMULTANEOUSLY:256 -- [i] <<<<<<<<<<<<<< End iceoryx_posh configuration: >>>>>>>>>>>>>> -- Configuring done -- Generating done -- Build files have been written to: C:/dev/ros2_galactic/build/iceoryx_posh 用于 .NET Framework 的 Microsoft (R) 生成引擎版本 16.10.2+857e5a733 版权所有(C) Microsoft Corporation。保留所有权利。

Checking Build System Building Custom Rule C:/dev/ros2_galactic/src/eclipse-iceoryx/iceoryx/iceoryx_posh/CMakeLists.txt ipc_runtime_interface.cpp version_info.cpp iceoryx_posh.vcxproj -> C:\dev\ros2_galactic\build\iceoryx_posh\Release\iceoryx_posh.lib Building Custom Rule C:/dev/ros2_galactic/src/eclipse-iceoryx/iceoryx/iceoryx_posh/CMakeLists.txt iceoryx_roudi_app.cpp roudi_app.cpp roudi.cpp

Rongcai gravatar image Rongcai  ( 2021-07-29 10:04:50 -0500 )edit

roudi.cpp process.cpp process_manager.cpp roudi_cmd_line_parser.cpp roudi_cmd_line_parser_config_file_option.cpp C:\dev\ros2_galactic\src\eclipse-iceoryx\iceoryx\iceoryx_posh\source\roudi\process_manager.cpp(190,93): error C2001: 常量中有换行符 [C:\dev\ros2_galactic\build\iceoryx_posh\iceoryx_posh_roudi.vcxproj] Building Custom Rule C:/dev/ros2_galactic/src/eclipse-iceoryx/iceoryx/iceoryx_posh/CMakeLists.txt iceoryx_posh_gateway.vcxproj -> C:\dev\ros2_galactic\build\iceoryx_posh\Release\iceoryx_posh_gateway.lib

Thanks

Rongcai gravatar image Rongcai  ( 2021-07-29 10:05:20 -0500 )edit

It seems an issue relate to language on windows. Once I added English Language support, it works now. I am not sure why only this file has such kind of issue but it works now. Appreciate any explaining if anyone have.

Thank you a lot.

Rongcai gravatar image Rongcai  ( 2021-07-29 11:34:09 -0500 )edit

Thanks for providing the output (although adding the file content to your post by editing your post and pasting the content would've made it a bit easier to read!). It looks like "error C2001" is common for Chinese-language Windows. If you google "Windows error C2001 Chinese" you'll find many results, and it looks like this is an encoding issue. I think that, by enabling English language support, you probably added the missing encoding support. Something about this is mentioned for the Ubuntu build/install instructions, but not for the Windows instructions, so I will add it. Thank you for mentioning the solution!

christophebedard gravatar image christophebedard  ( 2021-07-29 12:33:53 -0500 )edit