ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | Q&A answers.ros.org
Ask Your Question
0

Importing mesh .dae file in ros noetic

asked 2021-07-17 07:49:47 -0600

SC0d3r gravatar image

updated 2021-07-18 01:19:33 -0600

gvdhoorn gravatar image

Hello everyone. I am trying to import a mesh(.dae) file into .xacro in (ROS noetic):

<geometry>
 <mesh filename="package://ros_robotics/meshes/l_finger.dae"/>
</geometry>

but when I want to view model in rviz it gives this error :

ERROR 1626525294.722785369: Could not load resource [package://ros_robotics/meshes/l_finger.dae]: Collada: File came out empty. Something is wrong here.

I ran the $ rospack ros_robotics and the package is there(I have made alot of models in that package and it works)

.dae files are there too I check them with rosls command, but no matter what I do I cant load the files into rviz I have tried the file:///$(find ros_robotics)/... , file:///ros_robotics/... , package://ros_robotics/... , package://$(find ros_robotics)/..., just puting $(find ros_robotics)/... and etc

nothing has worked yet :(

I also put the files in urdf directory where the .xacro file is and reference it there in the file and it didnt work either. Just to mention that I am using the .dae files from this github repo.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2021-07-17 12:47:21 -0600

SC0d3r gravatar image

I solved my problem, the issue was that I was getting the .dae files with wget command and it ruined it somehow and that error message was not helping either, I thought the issue was that the rviz couldnt find the .dae files. finally I downloaded the files with curl and it is working now.

edit flag offensive delete link more

Comments

The error is pretty clear though:

Collada: File came out empty. Something is wrong here.

it doesn't say "files can't be found". It says "I tried to load your file, but after doing so, it appears empty".

gvdhoorn gravatar image gvdhoorn  ( 2021-07-18 01:20:34 -0600 )edit

But the files weren't empty and when I googled my question all of the answers were that it cant find your .dae files make sure to do this or that etc ...

SC0d3r gravatar image SC0d3r  ( 2021-07-18 01:35:58 -0600 )edit

No, the files weren't empty. But it says "came out empty".

That means after loading/parsing the file, the result was empty.

So the contents couldn't be interpreted successfully, which resulted in Assimp throwing away whatever the files did contain, leaving it with nothing.

Hence: "File came out empty".

gvdhoorn gravatar image gvdhoorn  ( 2021-07-18 01:40:17 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2021-07-17 07:47:24 -0600

Seen: 455 times

Last updated: Jul 18 '21