Ask Your Question
1

Caster wheel "drives" the robot instead of following it.

asked 2012-07-08 09:52:55 -0500

Capelare gravatar image

updated 2014-01-28 17:12:56 -0500

ngrennan gravatar image

Hi everyone:

You may be familiar with my robot and its problems by now... here comes a new one, yay!

I think that I'm going to let the problem self explain with a video. As you can see, on ~0:30 I turn the robot 90º and then, when I tell the robot to go straight forward again, the caster wheel oscillates instead of just following the main body of the robot, making the robot move more like a snake than a car.

Hints?

Thanks a lot,
Miguel.

Update: I've noticed that if I add a lot of weight to the caster, the oscillation tends to stabilize, but I don't think that's a solution, because I'm increasing the weight of the caster wheel by 300 times its original weight (3g to 0.9kg). Any other ideas?

edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
0

answered 2012-07-16 01:16:43 -0500

Capelare gravatar image

Well, I managed to solve this problem by changing the <inertial> matrix to something smaller... but since I'm not familiar with this calculations, I'm not sure if this is a good idea.

Anyway, it seems to work pretty well now, so I'm not touching it anytime soon :)

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2012-07-08 09:52:55 -0500

Seen: 467 times

Last updated: Jul 16 '12