"rviz2 compilation fatal error" - 5 packages not processed

asked 2021-07-07 11:08:11 -0500

Clark_Clark gravatar image

updated 2021-07-07 12:30:08 -0500

gvdhoorn gravatar image

Hello, I am new to ROS2 and tried to install rviz2 from a separate workspace using "colcon build --merge-install" from ~/rviz2_ws/src.

After 17 minutes of processing, I get a fatal error referencing no such file or directory. The actual message is below. However, I can open rviz using "ros2 run rviz rviz". I'm sure I will have issues when I try to do something in rviz because of the fatal error.

Has anyone seen this issue? I searched the forum but didn't find anything.

-- stderr: rviz_rendering                                     
/home/mnclark/rviz2_ws/src/rviz/rviz_rendering/src/rviz_rendering/mesh_loader.cpp:65:10: fatal error: resource_retriever/retriever.hpp: No such file or directory
   65 | #include "resource_retriever/retriever.hpp"
      |          ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
compilation terminated.
make[2]: *** [CMakeFiles/rviz_rendering.dir/build.make:145: CMakeFiles/rviz_rendering.dir/src/rviz_rendering/mesh_loader.cpp.o] Error 1
make[2]: *** Waiting for unfinished jobs....
make[1]: *** [CMakeFiles/Makefile2:344: CMakeFiles/rviz_rendering.dir/all] Error 2
make: *** [Makefile:141: all] Error 2
---
Failed   <<< rviz_rendering [16.1s, exited with code 2]

Summary: 2 packages finished [17min 40s]
  1 package failed: rviz_rendering
  1 package had stderr output: rviz_rendering
  5 packages not processed
edit retag flag offensive close merge delete

Comments

Just had the same error, and ti was because I had the wrong branch of rviz checked out - retriever.hpp was introduced for the Galactic version of resource_retriever, so if you're on Foxy like I am (or an earlier version), then both the Galactic and Ros2 branches won't build - just check out the correct branch and it will work fine.

efno gravatar image efno  ( 2021-07-15 10:24:34 -0500 )edit