Ask Your Question
0

unable to locate package problem on ubuntu 16

asked 2021-07-01 08:00:31 -0600

jaaz.gd gravatar image

Hello, I am struggling to solve this problem I am having and I would appreciate it if someone could help. During the read me installation file when it says to input 'sudo apt-get install ros-kinetic-desktop-full' it comes up with Unable to locate package ros-kinetic-desktop-full. I have received support with this problem and have failed to find a solution. this is restricting me from continuing. Do you know why this may be happening?

edit retag flag offensive close merge delete

Comments

Have you followed the setup instructions to configure APT to use the ros package directory?

APT-Sources: http://packages.ros.org/ros/ubuntu xenial/main amd64 Packages
Mike Scheutzow gravatar image Mike Scheutzow  ( 2021-07-01 08:37:57 -0600 )edit

Sequentially follow the steps given here- Installation

trunc8 gravatar image trunc8  ( 2021-07-01 13:22:52 -0600 )edit

i have followed all steps and still get the error, as well as using the above 'APT-Sources: http://packages.ros.org/ros/ubuntu xenial/main amd64 Packages' and i now get 'command not found.

jaaz.gd gravatar image jaaz.gd  ( 2021-07-01 13:57:22 -0600 )edit

Do not skip a single step from the installation guide. Did you run sudo apt-get update?

trunc8 gravatar image trunc8  ( 2021-07-01 14:28:11 -0600 )edit

Yes I have. I have not skipped any steps. I also ask for help at my uni and the tech supervisor that helped also got the same error.

jaaz.gd gravatar image jaaz.gd  ( 2021-07-01 14:33:54 -0600 )edit

They think it might be an error with the version as it says Ubuntu 16.04 however that version is end of life so we are using Ubuntu 20

jaaz.gd gravatar image jaaz.gd  ( 2021-07-01 14:34:38 -0600 )edit

Your question title is misleading. Kinetic packages are not available for Ubuntu 20.04. Either install it on Ubuntu 16 via a virtualbox or install ROS Noetic on Ubuntu 20.04. Quoting their releases page-

Every ROS release will be supported on exactly one Ubuntu LTS.

trunc8 gravatar image trunc8  ( 2021-07-01 14:53:51 -0600 )edit
1

@trunc8 You should make your comment the answer.

Mike Scheutzow gravatar image Mike Scheutzow  ( 2021-07-01 15:27:15 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
1

answered 2021-07-01 22:25:04 -0600

unable to locate package problem on ubuntu 16

Your question title is misleading. You should always make your system's OS very clear in the question. In this case, your system OS is Ubuntu 20.04.

Kinetic packages are not available for Ubuntu 20.04. You can either use Kinetic on Ubuntu 16 via a virtualbox or install ROS Noetic on Ubuntu 20.04.

Quoting their releases page-

Every ROS release will be supported on exactly one Ubuntu LTS.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2021-07-01 08:00:31 -0600

Seen: 50 times

Last updated: Jul 01 '21