Ask Your Question

Unable to locate ros-kinetic-desktop-full

asked 2021-06-25 16:32:50 -0500 gravatar image

So i have installed all the updates and kegs how we it cannot locate package. I have Ubuntu 16.04 and Ubuntu 20 but I have tried everything and can’t manage to get it working. I’m a beginner and I looked at previous answers and nothing seems to help. Also my Ubuntu doesn’t look the same as the tbe tutorial as mine is just a terminal so I was unable to change the software settings as done In the tutorial, please help.

edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted

answered 2021-06-27 09:22:14 -0500

ParkerRobert gravatar image

This may seem rather obvious, but just to check have you sourced the ROS packages:

echo "source /opt/ros/kinetic/setup.bash" >> ~/.bashrc
source ~/.bashrc

If you have sourced the ROS packages, you can try doing echo $ROS_PACKAGE_PATH in your terminal window, this should output /opt/ros/kinetic/setup.bash

edit flag offensive delete link more


yes i have, even though that step comes after in the tutorials, i have tried echo $ROS_PACKAGE_PATH however i still get the same 'unable to locate package error gravatar image  ( 2021-07-01 13:45:22 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower


Asked: 2021-06-25 16:32:50 -0500

Seen: 53 times

Last updated: Jun 27 '21