Ask Your Question
0

Autoware car following issue using Open Planner

asked 2021-06-15 22:42:29 -0500

yougeyxt gravatar image

updated 2021-06-16 12:06:44 -0500

Hi all,

I am trying to do some field test using the Autoware 1.13 Release + Open Planner. I would like test the car following scenario. The leading vehicle is travelling at 3m/s. The ego-vehicle is controlled using the Autoware+open planner. The parameters used for local planning are as below: image description image description

The ego-vehicle did not try to maintain a safe car-following distance (I assume it will maintain a safe gap with the same velocity with the leading vehicle). Instead, It approached the leading vehicle and made a hard brake to a full stop. Here is a video showing the process (sorry for the low resolution).

I am using default values for Internal ACC parameters as shown below: image description

And yes I am using pure pursuit to track the trajectory, the parameters used for pure pursuit are as below: image description

Is this caused by improper setting of some parameters? Any comments and suggestions are appreciated. Thanks!

edit retag flag offensive close merge delete

Comments

Hi @Hatem, could you please take a look on this? Thanks :)!

yougeyxt gravatar image yougeyxt  ( 2021-06-15 23:58:57 -0500 )edit

what is the value of "enableinternalACC" parameter?

what controller are you using? pure pursuit ?

Hatem gravatar image Hatem  ( 2021-06-16 07:21:46 -0500 )edit

Hi @Hatem, I did not find the "enableinternalACC" parameter in the code (Am I using the right version of the open planner for Autoware 1.13 release?). But I find the "use_internal_acc" parameter and it is set as False. I have uploaded the screenshot of parameters regarding to Internal ACC parameters in the main content (it seems I cannot upload figures in the comment).

And yes, I am using pure pursuit to track the trajectory and the parameters used in pure pursuit is uploaded above.

Thanks :)

yougeyxt gravatar image yougeyxt  ( 2021-06-16 12:14:08 -0500 )edit

Hi Hatem,

The line 627 and 657 in the file common/op_planner/src/DecisionMaker.cpp (I am using the branch openplanner.1.13 seems should be commented out? Is these two lines causing problems? The two lines of code are: desiredVelocity = 0; //for CARLA

yougeyxt gravatar image yougeyxt  ( 2021-06-16 19:59:16 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2021-06-17 02:57:37 -0500

Hatem gravatar image

If you set use_internal_acc to False, you shouldn't use pure pursuit, the stop go behavior is the expected behavior in this case. and you need to use another controller such as op_waypoint_follower.

if you want to use pure_pursuit, set use_internal_acc to True, and tune values (PushRatio, acceleration, deceleration) to adjust how smooth you want to follow other vehicles.

edit flag offensive delete link more

Comments

Got it! Could you please confirm that lines 627 and 657 in DecisionMaker.cpp should be commented out? It seems like a bug to me.

yougeyxt gravatar image yougeyxt  ( 2021-06-17 10:11:04 -0500 )edit

commenting them will raise another issue,

when you enable use_internal_acc "UpdateVelocityDirectlyToTrajectorySmooth" will be called and disabling it will lead to calling "UpdateVelocityDirectlyToTrajectory"

you can try to comment them and try, it is opensource !

Hatem gravatar image Hatem  ( 2021-06-17 10:34:11 -0500 )edit

Sure thing, just want to double-check it :) thanks a lot for the detailed answer!

yougeyxt gravatar image yougeyxt  ( 2021-06-17 10:38:07 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2021-06-15 22:42:29 -0500

Seen: 153 times

Last updated: Jun 17 '21