Problem with visualization of ar tag

asked 2021-06-05 13:17:20 -0500

FrancinaCarron gravatar image

updated 2021-06-09 05:44:49 -0500

Hi everybody! I'm using ROS kinectic. I'm working with an Ardrone Parrot 2.0 and I was trying to visualize the ar_track_alvar tags ( in rviz. It's correctly installed and worked perfectly with the usb camera example! However after changing the parameters of the launch file to the drone parameters, rviz doesn't show me the markers in the map. The launch file that I'm using is this one:


<arg name="marker_size" default="4.5" />
<arg name="max_new_marker_error" default="0.08" />
<arg name="max_track_error" default="0.2" />
<arg name="cam_image_topic" default="/ardrone/front/image_raw" />
<arg name="cam_info_topic" default="/ardrone/front/camera_info" />
<arg name="output_frame" default="/ardrone_base_frontcam" />

<node name="ar_track_alvar" pkg="ar_track_alvar" type="individualMarkers" respawn="false" output="screen">
    <param name="marker_size"           type="double" value="$(arg marker_size)" />
    <param name="max_new_marker_error"  type="double" value="$(arg max_new_marker_error)" />
    <param name="max_track_error"       type="double" value="$(arg max_track_error)" />
    <param name="output_frame"          type="string" value="$(arg output_frame)" />

    <remap from="camera_image"  to="$(arg cam_image_topic)" />
    <remap from="camera_info"   to="$(arg cam_info_topic)" />

First, I run ardrone_driver of ardrone autonomy (https://ardrone-autonomy.readthedocs....), then the launch file and finally rviz. I then add the camera (/ardrone/front/image_raw), the TF and marker to rviz. I also tried using the tf2 transform running in other terminal using the following script: rosrun tf2_ros static_transform_publisher 0 0 0 0 0 0 1 /ardrone_base_frontcam /ardrone/front/camera_info Anything of this worked and I don't know what to do. If anyone could help me I will be really grateful!

edit retag flag offensive close merge delete