Ask Your Question
0

Cmake Error "Could not find a package configuration file provided by "moveit" with any of the following names:"

asked 2021-05-10 09:02:23 -0600

mr18b082 gravatar image

updated 2021-05-11 03:39:47 -0600

gvdhoorn gravatar image

Hallo everybody, I am new here and have already looked for similiar questions but those solutions didnt fix mine. So my Programm is based on the moveit UR5 tutorial. Now i wanted to move the robot via a node and fix goal position. But the code is not compiling anymore throwing that error. I cant upload an image (> 5 points required) ?? So i copied the terminal. I am running Ros noetic and moveit 1.

I have isntall moviet with "Sudo apt-get install ros-noetic-moveit" and also tried is over source. None work. I hope anybody has an idea Thanks already

Terminal:

Could NOT find moveit (missing: moveit_DIR)
-- Could not find the required component 'moveit'. The following CMake error indicates that you either need to install the package with the same name or change your environment so that it can be found.
CMake Error at /opt/ros/noetic/share/catkin/cmake/catkinConfig.cmake:83 (find_package):
  Could not find a package configuration file provided by "moveit" with any
  of the following names:

    moveitConfig.cmake
    moveit-config.cmake

  Add the installation prefix of "moveit" to CMAKE_PREFIX_PATH or set
  "moveit_DIR" to a directory containing one of the above files.  If "moveit"
  provides a separate development package or SDK, be sure it has been
  installed.
Call Stack (most recent call first):
  BAC/CMakeLists.txt:10 (find_package)
edit retag flag offensive close merge delete

Comments

Try catkin clean -y && catkin build, otherwise uninstall and reinstall according to the tutorial instructions.

fvd gravatar image fvd  ( 2021-05-11 06:49:14 -0600 )edit

catkin clean didnt work because i cant install catkin_tools (tried all kinds of installation variations) and uninstall and reinstall didnt work either

mr18b082 gravatar image mr18b082  ( 2021-05-11 15:21:29 -0600 )edit

Sounds like you should fix your catkin_tools installation first. What are you doing for your install and how does it fail? Please add relevant links and details to your question.

fvd gravatar image fvd  ( 2021-05-11 22:44:19 -0600 )edit

I have installed catkin_tools like this awnser propsed https://answers.ros.org/question/3531... After trying catkin build this msg comes: "bash: /usr/local/bin/catkin: No such file or directory" I Have catkin installed and catkin_make works and the WS path is added to the bashrc, if that helps.

mr18b082 gravatar image mr18b082  ( 2021-05-12 11:36:15 -0600 )edit

That sounds like your catkin_tools install was not successful. Cleaning and rebuilding your workspace from scratch (which often solves problems with packages not being linked or found) can also be done with catkin_make (was it catkin_make clean?), but if you can't run catkin, it sounds like your installations might be in disarray and moveit might not be installed correctly either. Has the tutorial worked on your machine before?

fvd gravatar image fvd  ( 2021-05-12 21:27:03 -0600 )edit

Yeah that's the weird part everything worked fine. If I restore a backup it works aswell. I am going to try out a fanuc tutorial see if that works.

mr18b082 gravatar image mr18b082  ( 2021-05-13 01:46:20 -0600 )edit

I fixed it! i was missing a specific line in the cmake.. my bad but thanks for your help appreciate it al ot!!

mr18b082 gravatar image mr18b082  ( 2021-05-13 06:18:38 -0600 )edit

Instead of closing the question, please post an answer and specify which line you forgot in your CMakeLists.txt, so the next person who has this problem will know what to do.

fvd gravatar image fvd  ( 2021-05-13 06:46:58 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2021-05-24 09:05:11 -0600

mr18b082 gravatar image

So I just missed to add the packages to my cmake and package.xml.
moveit_ros_planning moveit_ros_planning_interface

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2021-05-10 09:02:23 -0600

Seen: 670 times

Last updated: May 24 '21