Ask Your Question
0

build external package [closed]

asked 2012-07-02 05:27:57 -0500

Astronaut gravatar image

updated 2012-07-02 13:33:31 -0500

mjcarroll gravatar image

Hello

I tried to install the external ROS package cereal_port from the svn http://isr-uc-ros-pkg.googlecode.com/svn/stacks/serial_communication/trunk/cereal_port/

But when i execute the rosmake i got the following error:

[ rosmake ] rosmake starting...                                                            
[ rosmake ] Packages requested are: ['cereal_port', 'roscpp']                              
[ rosmake ] Logging to directory /home/bojan/.ros/rosmake/rosmake_output-20120702-172116   
[ rosmake ] Expanded args ['cereal_port', 'roscpp'] to:
['cereal_port']                    
[ rosmake ] WARNING: The following args could not be parsed as stacks or packages: ['roscpp']
[rosmake-0] Starting >>> cereal_port [ make ]                                              
[ rosmake ] All 21 linesereal_port: 0.5 sec ]                     [ 1 Active 0/1 Complete ]
{-------------------------------------------------------------------------------
  mkdir -p bin
  cd build && cmake -Wdev -DCMAKE_TOOLCHAIN_FILE=`rospack find rosbuild`/rostoolchain.cmake  ..
  [rosbuild] Building package cereal_port
  Failed to invoke /opt/ros/fuerte/bin/rospack deps-manifests cereal_port
  [rospack] Error: package/stack cereal_port depends on non-existent package roscpp


  CMake Error at /opt/ros/fuerte/share/ros/core/rosbuild/public.cmake:129 (message):


    Failed to invoke rospack to get compile flags for package 'cereal_port'.
    Look above for errors from rospack itself.  Aborting.  Please fix the
    broken dependency!

  Call Stack (most recent call first):
    /opt/ros/fuerte/share/ros/core/rosbuild/public.cmake:203 (rosbuild_invoke_rospack)
    CMakeLists.txt:12 (rosbuild_init)


  -- Configuring incomplete, errors occurred!
-------------------------------------------------------------------------------}
[ rosmake ] Output from build of package cereal_port written to:
[ rosmake ]    /home/bojan/.ros/rosmake/rosmake_output-20120702-172116/cereal_port/build_output.log
[rosmake-0] Finished <<< cereal_port [FAIL] [ 0.53 seconds ]                               
[ rosmake ] Halting due to failure in package cereal_port. 
[ rosmake ] Waiting for other threads to complete.
[ rosmake ] Results:                                                                       
[ rosmake ] Built 1 packages with 1 failures.

Any Help please¿

edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by tfoote
close date 2012-10-07 10:14:56

Comments

Did you try rosmake --rosdep-install? Which ros version and os are you using?

allenh1 gravatar image allenh1  ( 2012-07-02 05:33:00 -0500 )edit

I tried :I got the error: rosmake: error: no such option: --rosdep-instal

Astronaut gravatar image Astronaut  ( 2012-07-02 05:38:55 -0500 )edit

Im using ROS Fuerte and Ubuntu 10.4

Astronaut gravatar image Astronaut  ( 2012-07-02 05:39:17 -0500 )edit

Ok. So you're running fuerte. Is this package meant to be used with fuerte?

allenh1 gravatar image allenh1  ( 2012-07-02 05:39:43 -0500 )edit

--rosdep-install is deprecated in Fuerte. The error has nothing to do with rosdep anyway.

Lorenz gravatar image Lorenz  ( 2012-07-02 05:39:46 -0500 )edit

yes its meant to be used with fuerte

Astronaut gravatar image Astronaut  ( 2012-07-02 05:44:35 -0500 )edit

3 Answers

Sort by » oldest newest most voted
1

answered 2012-07-02 05:39:14 -0500

Lorenz gravatar image

cereal_port could not be found in your ROS_PACKAGE_PATH. Have a look at this answer for short instructions to set up a local workspace and add packages from source to it.

edit flag offensive delete link more
0

answered 2012-07-02 06:28:59 -0500

Astronaut gravatar image

I triedout and it compiles also perfectly fine. But got some problems on istalling the gps_common package. Its from the http://ram.umd.edu/git/ros/gps_umd.git . But got problems

edit flag offensive delete link more

Comments

Please don't create a new answer when you just have a comment. This is not a forum. Please comment on existing answers or open a new question in case you have another question. Also, please always provide a complete error description including error messages. See http://www.ros.org/wiki/Support

Lorenz gravatar image Lorenz  ( 2012-07-02 08:52:24 -0500 )edit

ok. So for question about installing a scan_tools stack with csm and laser_scan_matcher have to open a new one? yes?

Astronaut gravatar image Astronaut  ( 2012-07-03 00:09:52 -0500 )edit
0

answered 2012-07-02 05:42:50 -0500

allenh1 gravatar image

Ok. So, after investigation, you are trying to use a ros electric package with ros fuerte. You might try using the unstable branch.

What brought you to this package? You may be able to find another package with fuerte support to accomplish the same task. Hope I was of use!

edit flag offensive delete link more

Comments

Why should cereal_port not build in Fuerte? I just tried it out and it compiles perfectly fine. No need for finding another package.

Lorenz gravatar image Lorenz  ( 2012-07-02 05:46:03 -0500 )edit

Question Tools

Stats

Asked: 2012-07-02 05:27:57 -0500

Seen: 1,135 times

Last updated: Jul 02 '12